Can I have more than one FMOD Studio (Mac) versions installed at the same time?

Hi, I am working on two different games with FMOD Studio and Unity, and I would like to instal the latest version of FMOD (1.04.06) for the latest game, but still stick to the old version (1.2.5) for the other game.

Is this ok and how should I go about the installation?

You can install two copies of Studio into different locations. When you double click on a project it will load in the last one installed, so you would need to one of the projects via to tool GUI to be sure.

I know this is old, but what about Windows? Is it possible to use two FMOD Studio versions side by side?

Yes. Just as on a Macintosh, you will have to install each version in a different directory. (The default install directory for FMOD Studio includes the installed version’s version number, so this should happen automatically.)

In addition, the .fspro filename extension will be associated with the version that was most recently installed. Because of this, if you want to open an FMOD Studio project in a version of FMOD Studio that you currently have installed, but which is not the most recently installed version on your machine, you will have to open that version of FMOD Studio manually, and then open the FMOD Studio project by selecting “File > Open…”

Many of our users work on multiple game projects at a time, each using a different version of FMOD Studio. As such, having multiple versions installed is not uncommon.

@joseph I tried that and it did not work. Even if in other directories. It still reverts back to the last installed version. Do you have a solution?

What do you mean by “it reverts?” How are you opening the two versions of FMOD Studio? What happens when you try to open the older-installed version?

When I test here, I’m able to run two different versions of FMOD Studio side-by-side without problems.

I try to “open with” the 1.08 version on another HD and it will still only open with 2.0 unless I uninstall 2.0.

I’m afraid I haven’t been able to reproduce this issue. When I use the “Open With” context menu command on an FMOD Studio project in Finder, I am able to select any of the versions of FMOD Studio I have installed. When I do, that version of FMOD Studio launches and attempts to load the project.

1 Like

Yeah, I tried removing all and reinstalling both even opposite ways. Sometimes computers like to be funny haha. I’m a flight sim dev and use it for that. (XPlane11/12) It’s just a hiccup for now, great software. :smile:


I’m glad to kow it’s not a huge problem for you.

If you think of any other details of how you install or run the various versions of FMOD Studio, we’d be interested in hearing them.

1 Like