Cannot change distance parameter values

#1

Hi,

I have been trying to use the built in distance parameter feature in an event, but would like to change the max value of 20 to the value I’m using in distance attenuation, since 20 is still really close to the player in game. For some reason, fmod won’t let me change the min and max values, although they are not greyed out, like the values in the other built in parameters.

Thanks,
Raphael

0 Likes

#2

I’m afraid I haven’t been able to reproduce this issue, which suggests I must be missing some important detail of your workflow.

When I test it here, I’m able to use the edit parameter window to change the min and max distance of a distance built-in parameter. When I click OK, Studio asks me where I want to scale the content on that parameter. How does this differ from what you’re experiencing?

What version of FMOD Studio are you using?

0 Likes

#3

Hello Joseph, thanks for the reply. I’m afraid it’s a bug (I’m using the latest version). I tried to create another distance parameter and the numbers were also not changeable. Only after I restarted FMOD, deleted the parameter and created a new one, the numbers on this one were changeable. I didn’t try to change the values on the parameter I already had right after restarting, so I can’t say if that one had been fixed before I deleted it.

Either way, it works now. :slight_smile:

0 Likes

#4

That suggests the issue must only occur under specific circumstances. That’s valuable information. Thanks!

I’ll continue trying to reproduce the issue. If I can get it to happen here, we should be able to isolate the bug and fix it.

0 Likes