Can't build game - Missing Files from FMOD

Hey, I’m having this issue that only appears when I try to build my game. Playing inside the Unity editor is fine.

  1. BuildFailedException: There is an FMOD binary missing for build target StandaloneWindows64:
    /Assets/Plugins/FMOD/platforms/win/lib/x86_64/fmodstudio.dll
    Please run the FMOD/Reorganize Plugin Files menu command.

Those folders are empty inside my game project files.
When I go to Reorganize plugin files inside Unity there are plenty of files missing from the lib (libfmod.L , fmod.dll , and plenty others)

What’s the best way to work this around?

What version of FMOD are you using? Have you tried reinstalling the FMOD Unity integration?

Hey Jeff,

FMOD Version: 2.02.03
Unity Version: 2019.4.24f1

I’ve tried removing all the folders related to FMOD and integrating it again in my project, but I had to do a backup from Github because too many errors started appearing.

What is the best way to reinstall it into my project knowing that I already have some scripts and calls using Fmod API?

Regards

Ideally you should only need to reimport the package, if you could share the errors with me I can help you get past them? Otherwise, you can usually get back to a good state by closing Unity, deleting “\Assets\Plugins\FMOD”, reopening Unity (ignoring the warnings about safe mode) and reimporting the 2.02.03 package.

The method of deleting the FMOD Assets folder and reimporting the package seems to have solved the issue. Now I can build my game again.
If anything arises in the meantime I’ll let you know.

Thanks!

1 Like