DLLNotFoundException

-Im Getting DLLNotFoundException error each time i close and reopen Unity.

-I tried deleting and re-importing Fmod and i made sure that the File Staging Is checked, but i still get the same error after closing and reopening Unity

-I’m working on 10 short VR Games and it’s happening with half of them

I’m using:

  • Fmod: 2.02.07

  • Unity: 2021.2.11, 2021.2.11f1, 2021.3.0f1 (I updated to the latest LTS version and the problem persisted)

  • Windows:
    Edition Windows 10 Pro for Workstations
    Version 21H2
    OS build 19044.1766
    Experience Windows Feature Experience Pack 120.2212.4180.0

Hi,

There are a couple of things that you can check:
Firstly check fmodstudio file exists in your Unity Project files here:
image

If it is not there please let me know.

If it is there then check the import settings for fmodstudio looks like this

You can open this window by clicking on the fmodstudio file.

Hope this helps!

The fmodstudio file does exist and the import settings are the same as the screenshot.

Could the problem be from updating Fmod “2.02.03” to “2.02.07”?
I deleted the “Fmod” folder from the “plugins” folder before updating so I’m not sure if I should have done it differently.

Hi,

No worries, let us try re-importing one more time.

When re-importing the package make sure to select the “All” option as this will select anything you are missing. Hopefully, the FMOD Setup Wizard will pop up, if not it can be opened from the FMOD drop-down menu along the toolbar of Unity. The setup wizard will prompt you to “Disable Existing Native Libraries”, follow the prompts and restart Unity. Again the FMOD Setup Wizard pop-up again, now prompting you to “Copy New Native Libraries” follow the prompts and finish the Setup Wizard to ensure FMOD is set up properly in the Project.

Hopefully this helps!