Failed to load Bank with Unity (Source-Control Conflicts?)


I’ve been facing an issue for the last few hours where I can’t find a way to load a master bank within unity. Everything worked fine until I changed the name of my reaper project file path in the asset panel. I change the name of the root where are contained my reaper, fmod and unity projects so I had to re-sync my reaper project with my fmod project. I know it is not something to do but I had to do it in order to unblock an odd situation with the source-control software (gitdesktop). I am pretty stuck with the situation. I tried to re-import the fmod plugin but each time I try to load a bank I got the following errors (see attachment), and when I try to play, none of my assets are launched. Does someone knows where to start ?

I suggest getting FMOD Studio and the FMOD Integration back into a default state, and once that’s working start moving back towards whatever your specific setup was.

  • In FMOD Studio
    • Delete the existing built banks
    • In Preferences>Build ensure “Built banks output directory (optional)” is blank
    • Rebuild banks
  • In the FMOD Settings
    • Change your Source Type to “FMOD Studio Project”
    • Change your Studio Project Path to match that of your .fspro project
    • Change your Import Type to “Streaming Assets”

Hopefully that should get banks importing correctly again, otherwise I would suggest completely removing Assets/Plugins/FMOD folder and then reimporting the FMOD Integration and going through the above steps again.
If that doesn’t work, please give me your FMOD and Unity versions and I will investigate further!

The solution was to reimport the FMOD plugin after completing a full clean up of the integration settings. Thank you !