FMOD 1.08 & Oculus Spatializer Plugin


(Xoe Baird) #1

I’m having trouble getting the Oculus SP to load in Fmod. I’ve copied the libovfmod.dylib file into the Fmod Plugin folder (in the app contents) as per the instructions. However, when I go into FMOD add effects, it’s nowhere to be seen.

Running:
Mac OsX 10.8.5
FMOD Studio 1.08.00


(Patrick Wadsworth) #2

Hi Xoe, what version of the Oculus plugin are you using?


(Patrick Wadsworth) #3

If you’re still having issues, you may need to contact Oculus to check that their plugin supports Mac OS X 10.8.5.


(Xoe Baird) #4

I’m loading in from Oculus Audio SDK Plugins Pack 1.0.3.
https://developer.oculus.com/downloads/audio/1.0.3/Oculus_Audio_SDK_Plugins/


(Patrick Wadsworth) #5

Hi Xoe,

I have tested this with the latest version of FMOD Studio (1.08.02) and Oculus SDK 1.0.3 and am able to load and use the plugin. Can you please check:

  1. The libovrfmod.dylib is placed under FMOD Studio (package) > Contents > Plugins.
  2. Do any errors appear in the log in Studio? You can view this by going to the Console window, under the Logging tab, after restarting Studio.
  3. If this still doesn’t work, try placing the plugin in ~/Library/Application Support/FMOD Studio/Plugins and restarting Studio.

(Xoe Baird) #6

I have worked out that it will only work on OSX 10.9 or Higher.


(Patrick Wadsworth) #7

This makes sense if the plugin only supports 10.9 and higher. Thanks for following up.