[FMOD] AsyncManager::asyncThreadLoop : System::update returned error 2


Using FMOD Studio 2.01.07 for Unity 2019.4.28f1, and I’m getting the following error on every frame in Development build for Windows:

[FMOD] AsyncManager::asyncThreadLoop : System::update returned error 2.

UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
FMODUnity.RuntimeManager:DEBUG_CALLBACK(DEBUG_FLAGS, IntPtr, Int32, IntPtr, IntPtr)

It only just started appearing after the integration has worked fine for nearly two years. After updating to 2.01.07 I have seen some problems in the Unity Editor such as intermittent crashes and audio sticking around after exiting playmode, but builds have always worked fine until now.

What can I do?

Managed to halfway work around this problem by setting all audio content to STREAM. I had previously avoided this because it causes different tracks to desynchronize, and I don’t consider it to be a solution just an indicator of what might be wrong.

It didn’t really solve the problem entirely either, since this problem popped up in its place: DllNotFoundException: Unable to load DLL ‘fmodstudio’: The specified module could not be found

The game only works in development builds now.

Looks like I solved this by increasing the number of virtual and real audio channels!

Glad to hear you got that working! FMOD_RESULT of 2 evaluates to FMOD_ERR_CHANNEL_ALLOC so increasing the number of channels makes sense- strange the error only ocurred post 2.01.07 though. If you can please share any logs next time you get a crash that would be appreciated.
Thank you for sharing your solution!