Fmod Build with no Sound Output ( Editor Works Fine)

Hey, i´ve been trying to get Fmod Running, with 3Daudio Implemented in an AR App. I’ve Integrated Fmod successfully and I´m able to hear all Sound and Ambiences in the Editor, with correct localization. Though there is just on small Problem !! While testing a Build on Android and IOS I cannot hear any sound playing in that specific scene. Has anyone encountered this kind of problem before?

-Thought i would be a bank load issue, but log is clean (no errors)

  • Also though I would be a Sample rate issue

What i’ve done so far:

-Checked all Fmod Settings to include mobile settings (fmod also has a Mobil bank file)
-Mobil Platform is in the Fmod Settings Menu
-Checked routing of all Objects and emitters (works fine in editor)

What i’ve also noticed

-Turning off all emiters and soundsources lets me still hear audio in editor
-Fmod debug shows -80db

I´m still pretty new to Fmod and Unity but i´ve been able to get a fine understanding though the forum but havn´t found anything on this topic before.

Thanks in advance

Odin!

Fmod Settings|259x500

I’ve been able to find the Problem. Turns out Fmod, in the compiled version, read the Fmod commands in the wrong order!! It tried to call an event, before the bank was loaded. Still don´t know how this happened. I ran an update of the Fmod integration and seemed to fix the problem in the Unity Build for Android.

Glad to hear updating FMOD fixed the issue, if you encounter it again on the new version please let us know.