FMOD Debugging in package

Hi,
I’m wondering is there an easy way to disable FMOD debugger to log into the logfile in packaged build!?
I looked into FMODStudioModule.cpp where it seems that FMOD_DEBUG_LEVEL_WARNING is hardcoded when the editor is not in PIE !?

Debugging is only enabled in builds that use the logging libraries of FMOD, which is any build other than shipping.

If you call Debug_Initialize more than once, it will basically overwrite the settings and use the newer ones. By changing the logging level in the FMOD UE4 settings it will overwrite the initial settings, and if you using FMOD_DEBUG_LEVEL_NONE it won’t use any debug logging.

Hi, thank you for your answer

Unfortunately I had no luck in overtiring the settings. I tried from my game module to call Debug_Initialize (called after FMOD plugin Debug_Initialize calls) and failed. Afterwards, I tried to change the plugin code in methods StartupModule() and SetInPIE(), I modified both to FMOD_DEBUG_LEVEL_NONE, and it also failed. It still logged to console and in the development package in the log file!? I tested it with EventInstanceSetParmater() where I sent the nonexistent parameter.

I’m using UE4 4.22.3 and FMOD plugin 2.00.05

Best, Dino