FMOD Studio: Encountered Error: ERR_VERSION The version of this file format is not supported

Also here is what my FMOD settings are showing:

I am able to link the Unity integration to the Studio project without any issues.

Can you share the entire Unity Console Log file?

This is all that shows up when I open the file:

That is just the console window, is there any more info in the actual log file:

Gotcha, I think… is this it? The Console utility has this repeated every few seconds:

That will be the file, are you able to share the entire file?
You can send it to if you prefer.

Just sent the .log file to that email

  1. The ERR_VERSION was caused by using banks built from version 2.0 in 1.10 API.

  2. The 2.0 Integration would not load because of a bug in the code, which has been fixed for an upcoming release and can be found on our github:

Ok. Is there a way of downloading the file you linked (do I need to log in to GitHub?), or do I need to wait for the upcoming release?

I don’t think you can download an individual file. You will need to edit the file (using Notepad will work) to either make the fix which is just adding a ‘+’ to two lines. Or you can copy the code from the entire file and paste it over the code from your current file.

I’ve really never done anything like that before, and I would most likely do it wrong. I’ll wait for the update, I suppose.
I appreciate your help, thank you.


No problem, the next release should be less than a week away. You could always use the 2.00.00 Integration until then.

Hi Cameron, I was wondering when the next release of the FMOD/Unity integration package will be available?

If its not for a while, I’m wondering if you could help me fix the file I have like you were mentioning in the previous emails? The way you explained it seems like an easy fix, but I have zero coding skills (I’m a composer)… also I couldn’t find “Notepad” on my MacBook. I see Notes, TextEdit and Terminal, is it possible to use those programs to find the lines in question and add ‘+’ to them?

I appreciate your help, I’m coming up on an important opportunity and I need to make an FMOD/Unity integration demo for a client.



1.10.14 & 2.00.02 are now available to download.

Hello again,

While I couldn’t get the FMOD tab to appear in Unity when using the 2.00.02 version package, the tab appears with 1.10.14. I was able to successfully link my FMOD project to a game object in Unity, but now when I click the play button there is no sound (I’ve checked that all of my settings are set to the right audio outputs, and that FMOD is set to “Desktop”). When I click stop, Unity freezes consistently every time I do this.

I’m going to try installing a different version of Unity (I currently have 2019.0.0a3 installed). **Can you point me to a version of Unity that should work with FMOD 1.10.14? **

Thank you again


The 1.10 integration will work with all fully released Unity versions back to 5.0.
The 2.0 integration will work with Unity 2017.4 onwards.

The alpha and beta releases, signified by the ‘a’ or ‘b’ in the version number, are not guaranteed to be supported. That being said, I don’t have any issue testing 2.00.02 in Unity 2019.3.0a4.

If you don’t see the FMOD menu it will likely be caused by a compile error, check the unity console window for errors.

Cameron I just wanted to say I am extremely grateful for your help. You were very timely and patient in your responses and of course enormously helpful. I am not a programmer and this entire process could have been enough to make me quit, but your assistance got me to the finish line.

I hope you get the recognition you deserve. Feel free to quote me on any of this.



1 Like

EDIT: Nevermind! I uninstalled FMOD studio and installed 2.00.12 instead and it worked fine!

I apologize if this thread is a little old to be resurrecting but i figured it would be better than making a new one. I’m having the same issue of receiving the “the version number of this file format is not supported” error. I just downloaded Fmod version 2.01.04 and I’m using Unity version 2020.1.3f1. If my screenshot uploaded successfully you can see it already has the code fix from that github file implemented into it.

What I find interesting is that when i first encountered this, the line “string pluginFolder = Application.dataPath + fmodLibPath + “/win/X86_64/”;” was shown as a collection of local variables and strings (yellow and green on my visual studio setup) while the code under each subsequent “#elif” was displayed as plain (white) text. I then tried the suggestion of deleting the banks from StreamingAssets and the Studio build directory as well as deleting and re-importing the unity plugin. After doing that, the “string pluginFolder = Application.dataPath + fmodLibPath + “/win/X86_64/”;” line of code is now also displayed as plain text. Could this be related at all? I’m still in the process of learning how to code so my knowledge is pretty limited.

Thank you for being so helpful to people on here!

FMOD 2.01.04 still has this error. Tried the fix in the runtimeultis script, still no changes. Also the script is 490 lines (default) instead of the 438 as shown in the script on the github repo. Any ideas?

FMOD 2.00.12 still works fine with no errors.

(Unity 2020.1.5f1 + Latest integration package from Unity Assest Store.)

The github repo has not been updated to FMOD 2.01.

This can be an issue if you are using assembly definitions: