FMOD Support for UE5

Unreal Engine 5 is now available in Early Access: Unreal Engine 5 is now available in Early Access! - Unreal Engine

Please can you give an indication of when we could see FMOD support for UE5? Any chance of support during the early access period? Or should we expect to wait until the full production-ready release?

Thanks!

2 Likes

It’s too early for us to give any indication of when we will have support for UE5, we only got preview access yesterday along with everyone else. We will be preparing support for the preview though and work will begin asap. The timeline will vary largely based on how different the plugin architecture is from 4.26. We will endeavor to make something available on our GitHub as soon as we can.

1 Like

Thanks for the reply mathew.

I have made some (fairly minor) changes to the 4.26 plugin source and now have it compiling and packaging properly for UE5EA, happy to share those changes if they will help.

1 Like

Glad to hear you were able to get it working easily.
If you’re willing to share your changes we’ll happily review them and compare with our current progress.

I’d be very interested in seeing what you did also.

@mathew @iodinex64

Please ref commit here: - tweaks to successfully compile and package for UE5EA · sp3n/ue4integration@7ebe994 · GitHub

1 Like

Thanks for sharing, our developer working on UE5 says they did similar changes.
We plan to create a 2.02-UE5 branch on GitHub soon to share what we have so far.

Be aware we aren’t planning to support 2.01 with UE5, integration support will begin with 2.02.

1 Like

@sp3n Hi! I’ve managed to get fmod to work in a windows build, but UE5 fails to produce an android build. The error I’m getting is;
ld.lld: error: /Plugins/FMODStudio/Binaries/Android/armeabi-v7a\libfmodL.so is incompatible with aarch64linux

Maybe I’m missing something here. Could you help me out?

Best regards,
Marcel

Okay, so I’ve managed to make it buildable, here’s what I did.

In the FMODStudio.Build.cs file, then replace this line:
string[] archs = new string[] { “armeabi-v7a”, “arm64-v8a”, “x86_64” };
with
string[] archs = new string[] { “arm64-v8a” };

The reason for this (I suppose) is that UE5 doesn’t support 32bit anymore.

If you get an error about a restricted folder, you’ll need to add this to your DefaultGame.ini
[Staging]
+WhitelistDirectories=PROJECTNAME/Content/FMOD/Desktop

Where PROJECTNAME is the name of your project (not the folder name the project is in)

Cheers!

You can also keep the “x86_64”, but don’t need to if you aren’t going to need it.

I have been testing all the platforms and that does appear to be all that is required at this point.

So to get this straight, use the latest version of FMOD and integration, put said integration files in a UE5EA project make the changes you’ve shown, and then just compile?

Basicaly yes. I work on a UE5 titel with FMOD and I just used the UE4.26 Plugin.

So I got fmod to work but when I try to make a custom class using fmod files it doesnt #include the fmod files it says it cant find directory/ doesnt exist. Any help here?

Have you followed the steps in the user guide that covers Programming Support?

Just wanted to add that it appears the FMOD validator tool to automatically add “FMOD/Desktop” to the “Additional Non-Asset Directories To Copy” packaging setting doesn’t seem to work when connected to Perforce. (I think it fails silently when DefaultGame.ini is read only). If you check it out first or just add the path manually it’ll work.

Just wanted to let anyone who sees this thread, it seems that FMOD has released their own UE5 integration, which can be found on their download page.