FMod UI Too Big Or Small

FMod’s default UI scale is very big on my screen, I tried changing Edit > Preferences > Interface > Force Device pixel factor to … but %100 is too small and %125 is too big.

How do I fix this?


Unfortunately, there’s no way to modify the pixel device factor in the Preferences menu outside of the values provided - as someone who uses a 1440p screen, I can definitely empathize with wanting a middle ground between the two values you listed, so I’ve added it to our internal feature/improvement tracker.

That said, as a workaround, if you navigate to your 2.02.00 config file, you can add or change the “forcedDevicePixelRatio” property to set a specific value:

		<property name="forcedDevicePixelRatio">

I find 1.15 to be a good middle ground, but feel free to mess around with it and find a value that suits you. If you do find one you like, could you please let me know what it is, and also your screen size and resolution?

If you’re on Windows, you should be able to find Studio.02.02.00.config at “C:\Users\YourUsername\AppData\Local\FMOD Studio\Settings”. If you’re on Linux, you should be able to find it at “~home\FMOD Studio\Settings”. The only downside to this is that reopening the preferences menu will reset the property in the config file, so you’ll need to set it again.

Thanks for the answer but when I tried it any thing under 1 would make it the same size as %100, and anything over 1.1 would make it the same size as %125

So that I can confirm the behavior you’re describing, what version of FMOD Studio are you using, and what platform are you on?

I’m using FMod 2.02.15 and I’m on windows 10.

Unfortunately, I cannot replicate the value-snapping behavior you’re describing.for values over 1. If I perform the following steps, I have no issue setting a custom scale with 2.02.15:

  1. Open Studio, go to Preferences → Interface, and enable “Force device pixel scale factor”
  2. Close Preferences and Studio
  3. Navigate to your Studio.02.02.00.config file
  4. Set the “forcedDevicePixelRatio” property to the desired value
  5. Save Studio.02.02.00.config
  6. Reopen Studio

Please give those a shot and see whether you can set the value without any issue.

Sorry it took so long, I tried it but nothing changes it also automatically unchecks the "Force device pixel scale factor” checkbox for some reason?

No problem. Unfortunately, I’m unable to reproduce that behavior on my end either. That said, a fix for this issue is in the works, and should be included in a future release.

I fixed it by getting a 1080p display

Not sure if this works in Windows 10, but in 11, changing the DPI settings on the shortcut did the trick for me.

Happy to hear you’ve found a workaround - a 115% pixel scaling option was added in 2.02.17 to provide an option between 100% and 125%, so give that a shot too if you’re able to.