UI Scaling for 4K Screens

Hey there, I am using FMOD Studio on 4K screen and the UI is so small that is basically impossible to read. Is there a way to enable UI scaling? In not, is there a plan to implement it?

I have the same problem. I’m using the native display scaling in Win10.

Is the question regarding FMOD Designer? If so, this is something that is unlikely to be fixed given that FMOD Designer is a legacy product. FMOD Studio should deal with high DPI displays more gracefully.

FMOD Studio. This is what it looks like on my desktop and it’s not a huge screen physically [FMOD Studio UI Image][1]
[1]: https://goo.gl/photos/Ja3Uy85MC1sKoskZ8

Hi Bojan and Bret,

It’s currently not possible to adjust the DPI settings of FMOD Studio independently of the operating system. You will need to adjust the DPI settings of Windows 10 through system settings and restart FMOD Studio to see these changes.

Please also note that FMOD Studio will take the highest DPI settings if two monitors are present - for example a laptop with 4k resolution and a secondary 1080p monitor will pick up the DPI settings of the laptop screen.

We have added a note into our task tracker to better accommodate high resolution monitors.

Thanks,
Richard

1 Like

Thank you Richard. I do have UI scaling in Windows set to 150% in fact and use only one screen.

Hi Bojan,

You may need to up the DPI a bit more. On my machine Windows is recommending 200% scaling. As mentioned, we are working on improving this.

Update: Since Studio 1.10.01 we’ve added experimental support for forcing the displayed device pixel ratio on Windows. This is available under the Interface tab of the Preferences dialog. We’re keen to know if adjusting this setting (i.e. to a number from 1 to 4) helps.

We do plan on further improving high DPI support in the future. Part of the issue relates to the 3rd party UI library we’re using, so we’re looking at upgrading this.

2 Likes

Thank you for looking into this again. I did update to latest (1.10.02) and the scaling does work. But it’s not helpful for me yet, as I can only set an integer value and 2 is already to large. Also the text kerning is a bit off for that value.

I am looking forward to new upgrades.

Hey Bojan.

Nice to see you on here.

Have you had any luck figuring this out or creating a workaround for this? I’m having he same issue where the scaling value of 2 is just too big.