FMOD Unity Path adding extra /Desktop/

Hello! I’m just trying to link my FMOD banks to my Unity project, using the latest version of FMOD and the Unity integration. I did recently update the Unity integration to this version if relevant.

When I try Single Platform, I navigate to Assets/FMOD/ and select, and the sound works, but the editor (FMOD settings in Unity) says that the location does not contain any built banks (and I can’t edit the settings). If I try selecting the Desktop folder, the editor shows up, but FMOD throws an error on startup, saying it can’t find anything under Assets/FMOD/Desktop/Desktop/. The same happens with both other selection methods as well. It seems to me that Unity is appending a /Desktop/ to the build path.

Now, the weirder part is on GitHub. I left it on Single Platform and Assets/FMOD, so that the audio worked (even though the banks were under /Desktop/). As soon as someone else opens the project, they get an error that the path is wrong - It’s looking for banks under Assets/FMOD/, the actual path I specified. I’ve tried rebuilding, redownloading the repo, messing with lots of settings, all to no avail. Any help?

Just to confirm, what version of Unity and FMOD are you using?
Can you please try doing the following:

  • Set Source Type to “Single Platform Build”
  • Set Build Path to “Assets/FMOD/Desktop”
  • In file explorer, go to “Assets/Plugins/FMOD” and delete the “Cache” directory
  • In the Unity menu, click through to FMOD>Refresh Banks

That worked, thank you!!

Edit: and I’m on Unity 2020.3.17f1 and FMOD 2.02.3.

I’m having this exact same issue. I’ve followed the steps suggested but it hasn’t worked. The Cache folder gets recreated almost instantly when I delete it.

The error says it can’t find in Assets/FMODAssets/Desktop/Desktop. If I create another folder within Desktop also called Desktop, the error says it can’t find in Assets/FMODAssets/Desktop!

I’m using Unity 2021.2.8f1 and FMOD 2.02.04

Can you please share a screenshot of your FMOD Unity settings?