Gain plugin in unity


We are trying to use the gain plugin that comes with fmod, but we couldnt find any integration docs. How can we load the plugin in unity???

Thanks in advanve,

Hi! thanks for the answer.

The problem is that I’ve already tried to copy the plugin, but Unity gives an error and doesn’t allow me to load it. The plugin I want to use comes with FMod, it’s not anything out from your the software.

I would like to know where are the files (.dll I guess?) I need to copy, and what about Mac, where are the plugins for Mac? If you could go a little deeper in the explanation, would be great.


Plugins are loaded using the FMOD Settings panel. See

You also need to copy the plugin files into the correct plugins folder (plugins/x86_64, plugins/x86, etc) in your Unity project and set up the Unity asset properties.

The plugin files can be found in the FMOD Studio installation folder. (c:\program files on windows, or applications on Mac) If you want the Mac plugin files you will have to download the Mac version of FMOD Studio or download the API installer which contains the source of the plugins to build yourself.

If you get an error message, can you post the contents, otherwise we cannot help you.

Hi, dead thread.

I am having a similar issue to this and there is remarkably little information online regarding it. (For those who don’t know this step, on Mac, open the applications folder, right click on the FMOD studio application and select show package contents then navigate to Contents -> Plugins). I’ve copied the .dylib files into the Plugins folder in my Unity Project and added their file names without the extension in FMODStudioSettings. However, I still get this error:

SystemNotInitializedException: FMOD Studio initialization failed : Loading plugin ‘fmod_distance_filter’ from ‘/Users/jacobmumford/Desktop/Art/Games/Elegy/Assets/Plugins/fmod_distance_filter.bundle’ : ERR_FILE_NOTFOUND : File not found.
FMODUnity.RuntimeManager.CheckInitResult (RESULT result, System.String cause) (at Assets/THIRD_PARTY/Plugins/FMOD/RuntimeManager.cs:148)
FMODUnity.RuntimeManager.Initialiase (Boolean forceNoNetwork) (at Assets/THIRD_PARTY/Plugins/FMOD/RuntimeManager.cs:266)
FMODUnity.RuntimeManager.get_Instance () (at Assets/THIRD_PARTY/Plugins/FMOD/RuntimeManager.cs:79)

It appears that the implementation is looking for a .bundle file instead of a .dylib file. I actually just looked and there is a Plugins folder that got moved into a subfolder, where I do see .bundles, but I also don’t have any clue how to turn a .bundle into a .dylib file. I am getting ready to just delete the distance parameters in my events which I think are causing this, because we are on crunch time, but if there is an answer I would like to keep them.


FMOD itself can load both standalone dylibs and bundles.
The issue is that Unity only recognizes and copies bundles to the standalone app.
Use the dylib and the following to make the bundle, then place the bundle in the Projects Assets/Plugins folder:

mkdir -p fmod_distance_filter.bundle/Contents/MacOS
cp fmod_distance_filter.dylib fmod_distance_filter.bundle/Contents/MacOS/fmod_distance_filter

Hi Cameron,
Could you please explain a bit more in detail these commands ? Do I need to type the exact same three of them ? If so, I have already created a bundle file, and then copy/pasted, both the bundle and the dylib files, into the plugins folder but I still get the same error…

Manually copy/pasting the files doesn’t always remove the file extension association.

“mkdir -p fmod_distance_filter.bundle/Contents/MacOS” - makes a bundle with the structure listed.

“cp fmod_distance_filter.dylib fmod_distance_filter.bundle/Contents/MacOS/fmod_distance_filter” - is one command, which copies the file specified into the bundle without the file extension.

Just replace fmod_distance_filter with your plugin name.

Thanks for the description.


I ran into the same problem and following the steps got rid of the error, but only in editor (with my platform set to iOS).

However, when I make an iOS build, I still see the original ERR_PLUGIN_MISSING error. Are there any additional steps I need to take?

iOS and tvOS require extra steps when using plugins: