I always get "ERR_INVALID_HANDLE for CHANNEL (0x7FE0009)" error when trying to play any sound

Hi everybody,

despite closely following the tutorial and trying multiple ways of playing sounds (like via StudioEventEmitter as well as via code: FMOD.RuntimeManager.PlayOneShot(…) or FMOD.RuntimeManager.CreateInstance(…path…).start() etc) it just never works for me.

Sounds never play and if I check “Enable API Error Logging” in the FMOD settings, I get the following errors for every sound I try to play:

For now, I am at my wits end. The FMOD project was created by a professional sound designer and I can successfully access all sounds via the Event Browser.
The Setup Wizard marks every category as green (Linking, Listener, Unity Audio, Unity Sources), and I have a FMOD Studio Listener component attached to the camera. I also tried reinstalling the FMOD plugin to no avail.

My simplest attempt is just having a StudioEventEmitter attached to a game-object inside the scene, with “Play Event” set to “Object Start” and “Event” set to an FMOD event.
Other attempts are calling FMODUnity.RuntimeManager.PlayOneShot("event:/SFX/Office_Open"); (and similar events) in various parts of the game. And yet another attempt goes like this _eventInstance = FMODUnity.RuntimeManager.CreateInstance("event:/Music/Ingame_Music") and then calling _eventInstance.start().
In all instances, I get the errors above.

I’m using FMOD 2.01.10, Unity 2020.3.3f1, and I’m on Mac OS 10.13.6.

Update: It works in an empty Unity3D project. Does anyone have an idea what could interfere with FMOD in our game, resulting in the above mentioned errors?

The errors in that screenshot indicate that the Studio Event Emitter doesn’t have any listeners. For 3D sounds, this can be because there are no listeners within the Studio Event Emitter’s attenuation range. For 2D sounds, it can be because the event’s volume is set to 0 for some reason, likely due to a Parameter being required to control it.
Here are my suggestions for each case:

3D sound

  1. On the FMOD Studio Event Emitter, tick Override Attenuation
  2. Move the event emitter’s sphere handles to a point where the game object containing your FMOD Studio Event Listener is definitely contained within the sphere

2D sound

  1. On the FMOD Studio Event Emitter, click on the Initial Parameter Values combo box and select a parameter
  2. Move the slider to some non-zero value
  3. Repeat for all parameters in the list

If you still aren’t getting any audio in that project then the problem might be deeper and I will need some more detailed logging information from you. If so, please go into FMOD > Edit Settings, and under Initialization change the Logging Level to “Log”, then run your scene again and send me all of your console output.

1 Like

Hi Jeff, thank you so much for the timely response!

You are right, it indeed seems to have been an attenuation issue. Our sound designer increased the attenuation on all sounds and now I’m hearing them in game, as well.

Still, the error messages persist. But they only appear due to me having checked “Enable API Error Logging” in FMOD settings which is unchecked by default.
Do you think it is safe to ignore these errors whilst everything seems to be working? Or shall I try to track them down (and post the complete log)?

Glad to hear that it’s working now! Those errors are actually part of an unrelated bug that will be fixed in an upcoming release, but are completely benign so are safe to ignore.

1 Like

Good to hear! Thank you, once more :slight_smile: !

Any news about this issue? I’ve been able to reproduce it too with FMOD 2.01.09 and 2.01.10 versions.
Also if I disable “api error logging” toggle in the FMODSettings ScriptableObject it makes hang whole editor, when an error occur.

Thanks for the additonal information, we have come across the API Error Logging bug as well. Both issues have been patched for the next release, which will be available by the end of the month.