I can not get FMOD studio to link to Unity for real time editing.


(Joe) #1

When I select ‘Connect to game…’ and choose local host in studio I get the result ‘Studio could not connect to “127.0.0.1”.’ I have tried to achieve this by selecting ‘Run in background’ in player setting and also by adding

define FMOD_LIVEUPDATE

at the start of the FMOD_StudioSystem.cs script. If anyone has any ideas why this is not working I would greatly appreciate it.

Thanks.


(Shark4) #2

To connect to game you must have your fmod project open on one part. In unity go to Edit->Project Settings->Player, You should see by default the Settings for PC, Mac & Linux Standalone, otherwise click on that tab. In that tab you’ll see Other Settings, under Configuration, Scripting Define Symbols write the “FMOD_LIVEUPDATE”. After press Enter and then voilà ! Click on the play button in unity editor, then go to your FMOD project and Connect to game, that should work.


(Joe) #3

Hi Philippe. Thanks for your response. I have done this now but still seem to be having the same problem. I have tried it this way with updating the script, checking ‘run in background’ and without doing either of these things and I still seem to get the same result. Not sure what I’m doing wrong.
Thanks again.


(Shark4) #4

witch version of FMOD and FMOD unity package do you use ? Also, do the bank load in unity is the same version of your Fmod project ?


(Shark4) #5

Too, be sure to undo all modification you do in your script, you should not have to play with then for connect live. And where is the ‘run in background’ that you talk ?


(Guest) #6

Just to be clear, the game is running inside the editor when you try to connect?