Importing profiler session error. What am I missing?


I’m using FMOD 2.01.06 on Windows 10 Pro (10.0.19042).

In the profiler, I right-click a session to “Package Selection…”, save it as a .fspackage with all options unchecked, then back in the profiler I right-click inside the “Sessions” area to “Import…”, select the previously saved session and I got the following error:

I’m probably missing something really simple, but I can’t figure out what :sweat_smile:

Many thanks in advance.

Could you please try going to the Event Editor window and selecting File > Package Project and ensuring the Profiler Session box is checked? Try importing again after this.

Hi Richard,

Event Editor > File > Package Project

Profiler Window > Right Click on the sessions space > Import… and I get the same error “does not contain any profiler session”.

Also, seems this method is for packing the entire project right? I want to pack / export just the profiler sessions, which I assume should be done here?



This is very odd.

The File > Package Project and selecting the profiler sessions is the same as packaging the profiler sessions directly with the context menu. I’ve not been able to replicate this issue using our projects - both ways of packaging sessions and importing them into FMOD Studio work as intended.

Does this happen with a new project? You can record just a regular event playing in the event editor window for the profiler session.

Hi Richard,

Yes, it sounds really odd to me also, I’ve captured a video using a fresh 02.02.00 install, same results:


Sorry if you have already done this - but could you delete the profiler session before trying to import again?

Hi Richard,

I’ve tryied deleting the existing profiler session before importing, same error.

Also, I’ve been collecting a bit more info, I asked a team mate and a colleague to follow the steps described in the posted video, and they got same results.

Two of us have tried with same FMOD projects in different computers and the other has tried with a completely different project, no luck.

We’ve done further tests after migrating our existing project to 02.02.00, still no luck.

I consulted our development team and they were able to replicate this issue. This will need further investigation into why this is happening to provide a fix in a future release.

In the meantime you can work around this by creating and saving a blank project then clicking File > Open and selecting the exported fspackage file. You should be able to get your profiler sessions this way.

Hi Richard,

Sounds good, many thanks for your time.