Installing Unity Integration in FMOD 1.10.7


(David MacDonald) #1

I’m a musician trying to set up FMOD and Unity for the first time for a project. I’ve found a whole lot of tutorials that all say that after I set up the Unity integration, I will see an FMOD menu. I’ve tried with the assets of my current project and with demo assets from the Unity store, and I’ve yet to get this to work. I got to Assets > Import Package > Custom Package, and select the FMOD integration package I’ve downloaded. I then tell it to import all, and it runs. When it’s done there are no obvious errors, but I don’t see anything about FMOD anywhere. No FMOD menu at all.

macOS 10.13.5
Unity 2018.1.8f1
FMOD 1.10.07

Any suggestions would be greatly appreciated.

EDIT: I discovered that if I start a new empty project and import the FMOD integration before any other assets, it seems to work normally. However, I can’t seem to find a way to get the FMOD integration imported and working in an existing Unity project.

Is there a way to make this work without starting the project over again?

EDIT 2: A few days later, I reopened the same project, and the FMOD menu is gone again in Unity. If I try to re-import, Unity says that all the assets are already loaded. I’m completely stumped here. Any help?


(Cameron Baron) #2

Can you try the following steps:

  • close Unity
  • manually delete the ‘Plugins’ folder
  • Open Unity project
  • re-import FMOD

If that still doesn’t fix it, check the Unity log files for any information.
https://docs.unity3d.com/Manual/LogFiles.html


(David MacDonald) #3

Thank you for the suggestions. When I try to re-import, a bunch of assets are grayed out. Even when I click “All”, they aren’t checked, and I can’t check any of the child folders/assets.

screenshot: https://i.imgur.com/1tY3CKU.png


(David MacDonald) #4

There are a bunch of errors in the log file that look like this, among others:

error CS2001: Source file `Assets/Plugins/FMOD/BankRefAttribute.cs' could not be found

Here’s a Pastebin of the whole log: https://pastebin.com/hEgpsZak


(Cameron Baron) #5

I would imagine that would be before you re-import the Integration because further down you can see it updating all the FMOD assets/scripts.

Does it still not work?


(David MacDonald) #6

Correct. There’s still no FMOD in the menu bar, so I can’t link an FMOD project or place any sound sources.


(Cameron Baron) #7

I don’t seem to be able to reproduce the issue here.
Are you able to share a project with us that we can test?
Otherwise if you can send us the log files:

  • fmod.log
  • fmod_editor.log
  • Editor.log (in the Unity AppData folder)
    support@fmod.com

(David MacDonald) #8

Where can I find these files? I don’t see any files with those names. I’ve looked in

~/Library/Unity
~/Library/Application Support/FMOD Studio
~/Library/Application Support/Unity


(Cameron Baron) #9

The fmod.log and fmod_editor.log should be in your project directory, next to the Assets folder.

The Editor.log can be found in: ~/Library/Logs/Unity/