FMOD disapears when I open a project in Unity


(schmidt) #1

Hi,
I have an issue with FMOD that disapears when I open a Unity project.
For example, I worked yesterday on a project with fmod, I quitted Unity and when I launched it today, FMOD is no more in the toolbar and no more seen as a plugin.

I tried to delete it, to import it again but there is only the folder, nothing in the toolbar.

The problem is that I also have to first import FMOD as a plugin, before starting or downloading a project (like viking village). It won’t appear if I start a project and during it, try to import this FMOD plugin…

It’s my 2nd day on unity with this FMOD, if you know this problem, It would be great if you could help me ! thanks a lot,

Felix


(Cameron Baron) #2

What version of Unity and the FMOD Unity Integration are you using?

You may be able to find some information in the Unity editor log files:
https://docs.unity3d.com/Manual/LogFiles.html


(schmidt) #3

I got Fmod 11002, it’s the last version, and same for Unity : 2.0F3


(Cameron Baron) #4

Can you try deleting everything except for the Assets and ProjectSettings folders then re-import the plugin.


(schmidt) #5

Yes I did it, still the same. I imported it again, refreshed …


(schmidt) #6

I maybe have an idea : I got several errors when I open the “viking village” project, it comes maybe from there ?
I got 42 alerts and 2 errors, here are some of them :

Errors :
Assets/Editor/CrossPlatformInput/CrossPlatformInputInitialize.cs(88,34): error CS0619: UnityEditor.BuildTargetGroup.WebPlayer' is obsolete:WebPlayer was removed in 5.4, consider using WebGL

Occlusion culling data is out of date. Please rebake

Alerts :

GameObject is active but a parent is inactive. Active state is now inherited. Change the parenting to get back the old behaviour!

Assets/Standard Assets/Utility/TimedObjectActivator.cs(82,47): warning CS0618: UnityEngine.Application.loadedLevel' is obsolete:Use SceneManager to determine what scenes have been loaded’


(Cameron Baron) #7

The error you mentioned is to do with the CrossPlatformInput scripts, errors will stop Unity from compiling the project but warnings won’t.