Not able to connect with Live Update Editor to UE4.24 (FMOD 2.07)

The project I am working on uses Perforce. Our Project tree works as follows:

General Project Folder

  • FMOD (Project folder)
  • UE Project folder
    -> Content
    -> FMOD (Banks)

I tried all possible solutions to connect the UE Project with FMOD, but it has never really worked. I tried all servers that are said in this forum and all possible localhosts. Is there anything that I am missing because we’re using Perforce?

Thank you,


Hi Theo,

Are you getting any error messages either as a dialog popup or in the Console view in FMOD Studio?

The error I get is

"Studio was unable connect to “localhost: as a connection error occurred: Socket Error. Please check that the IP address is correct, the game is running and live update is enabled.”

That is where I mentioned that I’ve tried all possible IP combinations:

  • port number, which is 9265)
  • localhost(9265)
  • Perforce server IP

The game is on and live update is enabled inside UE4.


If you are playing the game in editor, you should use the port specified in the Live Update Port settings (defaults to 9264).

That is the port I’m trying to use. But how should I write the address then?


I just tested this on Windows, using, and I was able to connect FMOD Studio 2.00.07 to UE4 4.24.3 while running the game in the editor.


Wondering if you are still have issue connecting after trying as the address for live update?

I’m getting the same error message. Using UE 4.25.1 with FMOD Studio 2.00.10.


If you are getting the same error (i.e. Socket Error), usually this means either the game is not running or the port number is incorrect.


Same issue here with UE4.22 and FMOD 2.00.06 in local host.
Live update enabled, port : 9264 (initial setting)
Editor live update enabled, port : 9265 (enabled manually but port number was initial setting)

I also tried editor live update only with port number 9264.

There is no error message on FMOD end. Only “Live update reconnecting” blinking.

Did you find a fix?

Have a good day!

Are you able to check the ‘Console Window>Logging’ to see if there are any errors?

Are there any errors or warnings in UE4?