ObjectProperty FFMODLocalizedBankTable::Banks is not initialized properly error (not using localization at all) [UE5]

Hello,

I’m experiencing an error similar to this thread when attempting to package for Windows 64-bit:

However in that thread it’s a warning, whereas the printout in my Output Log is an error and it’s the only error I get so it must be the thing causing my package to fail. The rebuild commandlet provided in that thread prints out the same errors:

LogInit: Display: LogClass: Error: ObjectProperty FFMODLocalizedBankTable::Banks is not initialized properly. Module:FMODStudio File:Private/FMODBankLookup.h
LogInit: Display: LogClass: Error: BoolProperty FFMODProjectLocale::bDefault is not initialized properly. Module:FMODStudio File:Classes/FMODSettings.h
LogInit: Display: LogAutomationTest: Error: UObject.Class AttemptToFindUninitializedScriptStructMembers will be marked as failing due to errors being logged
LogInit: Display: LogAutomationTest: Error: LogClass: ObjectProperty FFMODLocalizedBankTable::Banks is not initialized properly. Module:FMODStudio File:Private/FMODBankLookup.h
LogInit: Display: LogAutomationTest: Error: LogClass: BoolProperty FFMODProjectLocale::bDefault is not initialized properly. Module:FMODStudio File:Classes/FMODSettings.h
LogInit: Display: LogConfig: Warning: GConfig::Find attempting to access config with non-normalized path ../../../../HEAVY AS STONE/Unreal Engine 4/HAS_master 5.0EA src/Config/DefaultGameplayTags.ini. Please use FConfigCacheIni::NormalizeConfigIniPath before accessing INI files through ConfigCache.

Also, I don’t have/have never had any localized tables in FMOD, but for the sake of this error I (tried to) make a bogus/placeholder one and I set it up in the Unreal settings too, to no avail.

So the fixes listed in that thread don’t help me.

Here’s my FMOD settings:


I tried changing the master bank name a few times, stopping at “MasterBank” as you can see here. I also tried another couple fixes for sort of irrelevant errors that involved changing the content browser prefix and additional non-asset directories to cook from “FMOD/Desktop” to something just like “FMOD” or something like that, I forget the exact “fix”, but it didn’t fix it.

I waited until 2.02.07 / the UE5 update came out today until I made this post, just in case updating would have fixed it (it didn’t). I deleted binaries and intermediate and rebuilt then retried packaging and still nothing.

No clue what to do…

OK I feel really dumb, but I got really fed up with this error and just edited the code myself. The two offending files’ USTRUCT constructors:

FMODSettings.h’s FFMODProjectLocale USTRUCT constructor line 209:
bDefault=false;

and

FMODBankLookup.h’s FFMODLocalizedBankTable USTRUCT constructor line 22:
Banks=nullptr;

My game packages fine now. Should have done this ages ago; what a waste of time lol! Really annoying that I didn’t haha.

I haven’t verified if sound etc is working but at least those errors don’t totally block my packaging.

EDIT: Yeah game works fine.

This only showing up as a warning for me in UE5.0.1- are you on the latest version of UE5 and FMOD(2.02.07)?

Yes to both! I’m on ue5-main branch source code actually. Latest commit I’m on is from May 7th (commit 0780ff4).

I see, thanks for the extra info. Looks like a few other people have been complaining about warnings like this with the latest UE version. This can be easily resolved by initializing the properties as you have done, so I’ve created a task to address this. Thanks for flagging!

1 Like