OculusSpatializerFMOD path issue on Build Oculus VR

We are using FMOD 2.01.02 - in Unity 2020.1.3

We are having issues with F-MOD DLL Pathing issues. In a build FMOD is unable to find the DLL See the error below.

SystemNotInitializedException: [FMOD] Initialization failed : Loading plugin ‘OculusSpatializerFMOD’ from 'C:/Users/Bester/Desktop/VaultAudioHeadsetTest/Vault of Stars Alpha_Data/PluginsSystemNotInitializedException: [FMOD] Initialization failed : Loading plugin ‘OculusSpatializerFMOD’ from ‘C:/Users/Bester/Desktop/VaultAudioHeadsetTest/Vault of Stars Alpha_Data/Plugins/OculusSpatializerFMOD.dll’ : ERR_FILE_NOTFOUND : File not found.

All Plugins in a build are located in Vault of Stars Alpha_Data/Plugins/ x86_64

Easy fix change the path to:

/x86_64/OculusSpatializerFMOD.dll

However when attempting to run in the editor now:

Users/Bester/Desktop/Vault of Stars Alpha/Assets/Plugins/FMOD/lib/win/X86_64/x86_64/OculusSpatializerFMOD.dll

FMOD then fails to launch in the Editor.

Our work around it to stacking the X86_64 Folder so there is one in each folder.

So were you able to fix it that way? Your issues sound very similar to the ones I had myself. In case this is useful: Oculus Spatializer + Fmod + Unity

Yes, duplicating the DLL and placing it where the build wants it, and also where the editor wants it, does fix the issue. I don’t see a way for me to fix the build path, I think it will need to be addressed by FMOD.

1 Like

Hi, thanks for letting us know about this. The plugin location was changed in Unity 2019, but our code had not been updated to match. This issue has been fixed for the next release.

FMOD 2.01.04 has now been released, including this fix.

That is awesome - thank you!!

It’s broken again on 2.02.09.

Hi,

A couple of things to check.
First is the .dll in the Assets > Plugins > Plugins > FMOD > platforms > win > lib > x84_x64 folder. Secondly, the plugin is added to your FMOD Settings:

Hi Connor. I solved the issue but as I mentioned before it’s all provoked by the Oculus plugin getting installed in the wrong folder by default. The DLL files need to be manually moved to the correct folder after installation.

1 Like

Hi,

Thank you for bringing this to our attention. I was able to reproduce the issue and will pass it on to our development team to look into it further.