2.02.17 SystemNotInitializedException: [FMOD] Initialization failed : Loading plugin 'OculusSpatializerFMOD' from '__BAD PATH__/Assets/Assets/Plugins/FMOD/platforms/win/lib/x86_64/OculusSpatializerFMOD.dll' : ERR_FILE_NOTFOUND'

Unity: 2019.4.40
OS: Win 10,

I’ve updated from 2.02.06 to 2.02.17 of both Studio and Unity integration package,
I’m using Oculus Spatializer OculusSpatializerFMOD carefully written into dynamic plugins of both Editor and Windows platforms
When I hit the Play Button, FMOD ceases to initialise and throws:

        SystemNotInitializedException: [FMOD] Initialization failed : Loading plugin 'OculusSpatializerFMOD' from '_redacted_/Assets/Assets/Plugins/FMOD/platforms/win/lib/x86_64/OculusSpatializerFMOD.dll' : ERR_FILE_NOTFOUND : File not found.

Notice the Assets/Assets/ part…

If I change line 82 in PlatformPlayInEditor.cs like this:

– string platformsFolder = $“{Application.dataPath}/{RuntimeUtils.PluginBasePath}/platforms”;
++ string platformsFolder = $“{RuntimeUtils.PluginBasePath}/platforms”;

Play in editor works, Bulid works

Great work, though

1 Like


This is a known issue that is being resolved in the next release. Thank you for sharing your workaround.

I am really sorry to write this, but in 2.02.18 - its still not working. What is even worse, the fix above is not working anymore. I am not getting any sound. When I tested the same thing in 2.02.17, fix worked…

1 Like

I am taking it back - somehow, I don´t know why or when, FMOD setup wizard added two listeners to the same object. I deleted one of them and suddenly it started working. Sorry : )

1 Like


No worries, thank you for sharing the solution.