Opening Preferences Crashes

I just updated my OS to 12.4 and am doing a bunch of software updates to go along with it. I downloaded FMOD 2.02.07, and now whenever I try to open the Preferences FMOD immediately crashes. I tried rolling back to 2.02.06 and 2.01.16, deleting my FMOD application support folder, and deleting my fmod plist in my /Library/Preferences, and am still getting the crashes.

Any thoughts?


Thank you for providing the steps to recreate this crash. I was just hoping for some more information about your setup?

Looking into the crash log it appears to be crashing when an audio device reports over 32 channels. Do you have a device plugged in that provides over 32 channels?


Yes I do, I tried unplugging it and had no problems opening preferences.

Is FMOD incompatible with audio interfaces with over 32 channels? I have about 30 computers with FMOD and audio interfaces this size, if this is the case I will probably have to stop supporting FMOD…

Thank you for confirming, unfortunately the max channel count in FMOD Studio is 32, which seems like a real oversight. Thank you for bringing this to our attention, I have passed this onto the Dev team to investigate further and fix in a future release.