Packaged project on non dev pc has no sound bu on dev pc does. (DLL MISSING)

The issue:
We developed a custom dsp dll where we could use it with fmod studio and on unreal editor but when packaged project everything is fine. But after copying the package to a target pc platform (no development tools is installed on this pc) it throws the couldn’t load customdsp.dll or customdspL.dll into the log and plays no sound.

What versions are we using:
Unreal Engine 5.2 epic’s version
FMOD Studio 2.02.15
FMOD Unreal Integration 2.02.15 for unreal engine 5.2
Our custom dsp compiled with VS 2019

What we did:
Checking documentations about making, using and deploying custom dsp dll. (FOR SEVERAL TIMES)
Checking our unreal engine projects settings in regard to what documentation suggested. (FOR SEVERAL TIMES)
Copying custom dll to every possible project related locations on our target pc platform (no luck).
Installing the FMODStudio 2.02.15 on our target pc and still the package didn’t work.
After trying last step, copying custom dsp dll into Program Files/FMOD SoundSystem/FMOD Studio 2.02.15/plugins. then, making an event trying to use the custom dsp dll and the plugin didn’t show up.
Building fmod_gain example code for target x64 platform using dev pc and copying into previous step’s location on target pc platform, and again couldn’t find the fmod_gain plugin in fmodstudio on target platform.


Thank you for all the information. Can I confirm, when referring to the package you mean the game packaged from Unreal Editor? If I am mistaken can you please let me know what application is not able to load the custom plugin?

If it is the game that is unable to load the plugin, can you please check: "UnrealGame"\Windows\MyProject\Plugins\FMODStudio\Binaries\Win64 for your custom plugin .dll.

Hi Connor, Thank you for clarifying. Yes, by “package,” I am indeed referring to the game packaged from Unreal Editor.

I’ve checked and can confirm that the custom plugin (.dll) is present in the specified directory: “UnrealGame\Windows\MyProject\Plugins\FMODStudio\Binaries\Win64.” I also attempted to manually replace the .dll file with the one from my working FMOD Studio plugins folder, but unfortunately, the issue persists.

I’ve been dealing with this issue for a couple of weeks now and tried lots of different strategies. As a last resort, I installed Visual Studio with C++ oriented packages and fixed the issue.

At the end of my last message, I referred to another issue on the target platform, PC. I found out that FMOD Studio can’t find the custom dll too. I’m not sure if it’s possible for you to recreate the issue or not, but the steps for recreating the issue are as follows:

  • Compile and build fmod_gain with Visual Studio using FMODEngine 2.02.15 examples.sln on your primary development machine.
  • On another machine, install a fresh copy of Windows 11 or 10.
  • Install only GPU and audio drivers.
  • Update Windows.
  • Install FMOD Studio 2.02.15.
  • Copy the fmod_gain.dll compiled in the first step.
  • Start FMOD Studio.
  • Create an event, a timeline, and an audio track.
  • Try to find and add an effect plugin from FMOD->fmod_gain to the track.
  • Manually add the plugins folder in FMOD Studio preferences.
  • Try again to find and add an effect plugin from FMOD->fmod_gain to the track.

If you require any further log files or information, I’m happy to provide.

Thanks in advance.


Thank you for the reproduction steps.

The issue may be your plugin’s dependency on C++ runtime. There are two solutions, either you can distribute the Visual C++ runtime with your Unreal package. or you can statically link the C++ runtime in your custom plugin Visual Studio Project.

Hope this helps

The issue was related to the Visual C++ runtime, not due to the absence of Visual C++ runtime but rather the difference between the debug and release versions. I had initially configured the project with debug x64 build settings, causing all dependencies to be debug counterparts. Upon switching to release x64 settings and revisiting the dependencies, I discovered another dependency linked to a debug version. Resolving this dependency fixed the issue.

Debug versions of Visual C++ runtime libraries typically end with the letter D and are not part of the official VCRedist package.

Thanks Connor.

1 Like


Thank you for sharing the solution.

If there is anything else we can assist with please do not hesitate to ask!