Packaging for PS4 - events not found


I’m trying to package my project for PS4 but I’m getting the following errors:

Couldn’t find file for package /Game/FMOD/Events/UI/ui_switch_tab /Game/FMOD/Events/UI/ui_switch_tab
Couldn’t find file for package /Game/FMOD/Events/UI/ui_switch_option /Game/FMOD/Events/UI/ui_switch_option
Couldn’t find file for package /Game/FMOD/Events/UI/ui_start_game

It seems all assets are missing in PS4.

I can confirm I have built all banks for PS4 (I’m only using the Master Bank). In the Explorer I have the following folder structure:


However, I noticed that on Unreal Editor, the Content Browser shows the “PS4”, “XboxOne” and “Desktop” folders as empty. There is also a “Banks” folder, this one does show the “Master_Bank” file.

I have also included “FMOD” in “Additional Non-Asset Directories to Package” in Packaging Settings.

I can also confirm I have added the PS4 binaries in the “Plugins” folder.

This is only happening when packaging for PS4 (XboxOne hasn’t been tested yet and Desktop worked fine).

I’m using Unreal 4.17.1 and FMOD Studio 1.10.00.

Any help?

When the FMOD plugin starts up it loads the information from the banks into ‘in-memory’ assets, these show up in the UE4 editor instead of the actual banks to make it easier to use.

One way to get rid of the warnings is to add a few directories to the “Directories To Never Cook” list:

  • “FMOD/Buses”
  • “FMOD/Events”
  • “FMOD/Snapshots”
  • “FMOD/Reverbs”

These directories are where all the ‘in-memory’ assets show up and are rebuilt when the game starts up.

Is this causing any unwanted or unexpected behavour in game?

Thank you for the reply. Unfortunately, when we try to cook ok on the fly, the game crashes immediately. Will this solve this problem?

I don’t believe this will solve any crash related issues.
Do you have a log from the crash?

I’m having the same exact issue… No solution yet… The game doesn’t play any sounds, and I’m trying to build for PC

If you are able to send a log file through to it may help in finding the issue.

Guys, I am trying to get to the root of the same problem at the moment. What I have figured out so far is that it seems to go away when I disable event driven loader (EDL)

I have same errors in dedicated server (server wants to send rpc with guid of FMOD event).
I’ve solved this with this fix