Playing and event that is already started will not replay the event

Hi
In Unity, whether it’s from code or from the editor, if I play an event with Studio Event Emitter component, the event will not replay, its just do nothing.
Is there a way to make the event either replay from start, or start another instance of the event so they get played at the same time,
for example an event for playing bullet effect, if you play the event a second time, there will be another bullet effect that get played asynchronously with the first instance.
Thank you.

Is the event oneshot (does it finish by itself)?
Is it detected by Unity as oneshot?
Did you limit the number of max instances of this event in FMOD Studio?

1 - honestly I don’t know what are the factors that marks the event as oneshot.
2 - yes Unity detects the event as oneshot.
3 - no.

It seems no one want to answer.

You should post a screenshot of your Studio Event Emitter Component settings, and better describe the content of your event and the wrong behavior. Does it play correctly the first time? Did you try to replay the event while the first sound is still playing? After it has stopped? etc…

I’d be happy to attach some screenshots, but I didn’t know such problem needs such details!
Yes it plays correctly the first time, the event plays correctly every time I play it as long as the event is not currently playing, the problem occurs when I want to replay the event while it still playing, but after its finished I can replay it correctly.
Hope that is enough details.

Component : image

Event in studio :

as you can see the event is fairly simple.

Screenshots are useful because it can show details you forgot to mention.
I’m surprised your event is marked as “stream”, though it’s only 350 ms long. The usual practice is to set as streaming assets which are long (>10s) and not frequently accessed ; since yours is short with frequent access, it should be in RAM. Maybe that could be the reason of the lack of reactivity when playing the sound two times in a row…

Yes I marked the audio asset manually as “stream” because it is not frequently used in my situation,
however the problem resides even if the asset is marked non “stream”.
I’m assuming there is an option or setting or something that can change such behavior.

This really sounds as if you limited the instances to 1 with stealing to none, somewhere. Even though your event is correct, check each bus of the chain in the mixer view (including master) and look for such limitation. Exemple on the master bus:

All my mixer channels’ 'max instances" property are set to “infinite”.

Though I’m not a Unity user, I’ve tested the event emitter and it behaves as it should with oneshot events: it stacks another instance when replayed.
A few more ideas:

  • check/update the version of Unity, FMOD and integration plugin
  • recreate your Unity object from scratch
  • test it with other trigger methods
  • recreate your FMOD event from scratch, with other and longer assets