Scatterer ticks and playback issues

Hi y’all,
I love the scatterer instrument, because it allows some approach of granular playback, making the used material much more versatile.
However more often than not when using the scatterer instrument I experience theres a ticking sound in around one in 10-20 spawns. It sounds as if some of the spawns are being cut off abruptly, but never the first one(making me almost certain it’s a cut-off sound and not a cut-in sound).

Another issue with the scatterer I sometimes experience is that the whole event stays quiet entirely, when testing it in either Studio or Unity. When other events have been played back in the meantime this sometimes fixes it and the scatterer would make sound again to then fail 3 or 4 attempts later. It feels rather buggy.

I tend to make a simple event with a Single Instrument with a one seamlessly loopable(!) sound in it, set to loop, and give an AHDSR on the instruments volume knob, or should this be on the audio track? I’d give this instrument a random start offset. I would then reference said event in the scatterers’ playlist once. I’d give it a rather limited polyphony(3-5 since we’re developing for Oculus Quest and can’t handle too many simultaneous sound sources) and set the spawn stealing to none, since I expect this to just finish the volume envelope before starting a new “grain”. Yet this approach seems not to be working exactly as I’d expect with the clicks and sometimes complete sound drop out.

I’ve tried to put the sound file directly into the scatterer, but this seems to work better when the playlist is populated with shorter sounds rather one long sound with a random start offset.

My general question would be:
How do I make sure the single file grains that are spawned have a proper volume envelope before a new one is spawned?

I’m using FMOD Studio 2.02.09.
Any insight is much appreciated!

Jorick

Another thing I noticed is that when spawn stealing is set to None and the polyphony is set to an amount the spawn rate/interval would exceed, there is still voice stealing happening. This happend with both the shuffle/random and Sequential playlist settings and the Conditions polyphony/stealing.

Is there a way to actually prevent voice stealing to prevent cutoffs when the length of the AHDSR is randomized and only spawn a new instance when there is room for a spawn within its polyphony? It feels as though the Spawn stealing settings don’t actually make any difference.

I also observed cutoffs when the max polyphony was not even exceeded. What am I missing here?

Hi,

Unfortunately, I was not able to reproduce the issue.

Would it be possible to get a copy of an FMOD Studio project experiencing the issue?

Finally tracked down where the issue of the Voice Stealing came from: myself! I had set the Max Instances of the Master Track of the referenced event used in the scatterer to just a few voices at a time. Hence the voice stealing.

1 Like

Hi Conner, thanks for getting back to me.
I’ve also found the fix for my cut off spawns. It was due to my misconception that the Play Count of the source instrument was set to 1, which I thought was Loop Count, instead of play count. Silly me.

Even though the source instrument was set to loop and async turned on, when the spawn would reach the end of the file it would just cut off, rather than loop. I had been looking in the wrong place for the problem, because I thought turning on loop would definitely make it loop. I had set it to 1 thinking it was loop count because I didn’t want it set to infinite loop in fear of loose ends. For the sake of preventing confusion in the interface I would’ve put the play count next to the Cut button instead. I got misled by the tooltip of the Loop button.

My initial workaround was to set the Start offset less than 50% and the start offset Randomness to less then a 100% so that the spawn would never reach the end of the file. However when using a shorter source file this would not have been desirable since you’d basically never properly hear the end of the file, thus being less efficient or just not have the desired effect.

Solution of cut offs: Set source Play Count to more than 1.

I’m still looking into the scatterer sometimes not playing anything. I’ve sent you the project by message. Is it possible that I mistook the Trigger Behaviours’ Probability’s Chance slider for one that influences the individual spawns, rather the whole scatterer instrument?

Edit: And if so, what is a use-case of having a Polyphony in the Trigger behaviour is this is already done in the Master Track and within the instrument spawner itself?

So let’s say I have one 30-second file that I want to granularly play a small portion of to form a cloud of spawns, what is the best or cheapest way to make the spawn’s volume envelope smooth like a sinus or triangle?

Glad to hear you solved you found the solution.

I will make a note in for our documentation to better explain the Play Count.

I will link you to some documentation that might help. FMOD Studio | Instrument reference for the Trigger Behavior. FMOD Studio | Instrument Reference for the Polyphony behavior.

Could you elaborate on what you mean by the instrument spawner itself

This is a feature that is currently in development