Scatter Instrument - Attempting to schedule a sound in the past

Hey people!

So I’ve set up scatter instruments on my ambiences but I keep getting console spams with this warning on it.

‘[FMOD] PlaylistInstrumentInstance::startFullLengthHook : Attempting to schedule a sound in the past, this could cause inaccurate playback.’

I’ve seen in the forums and across the internet other people encountering this issue with scatter instruments and I’m wondering how to fix this?

I have preload sample data on each event emitter and ‘load bank sample data’ selected in the initialization settings but still I keep getting this warning.

I’m using FMOD 2.02.04 and Unity 2021.2.16f1.

Many thanks for your time!

This could happen if your event is large or complicated, or their instruments’ assets are large or set to streaming, and FMOD is having trouble triggering instruments at the set times.

Are you able to post a screenshot of your scatterer instruments event? How large are the assets its triggering?

Hey RIchard,

Thanks for replying! I think the event is not too complex, could it be I’m playing it alongside a larger loopable file? the Scatter instrument is scattering bird sounds ranging from 1s-3s and the spawn interval isn’t too close together either.

Here’s a screenshot of the event with the scatterer focused.

Hopefully this gives more insight into the problem as the dev is a little worried about the warnings so hopefully it’s fixable.

This looks to be a regression bug that was originally fixed in 2.01.11 but has since come back. The actual warning is benign and is just saying the instruments the scatterer is spawning aren’t triggering at the time it is expecting. This seems to only happen if your playlist has 6 or more instruments. Thank you for bringing this to our attention.

Thanks for clearing that up Richard! While I’ve got you is it okay to check one more thing?

At the moment we have the scatterer instrument placed and following directly on the player, obviously the problem there is the sounds get scattered but follow the player and have no distance attenuation so don’t sound truly in a 3D space.

This is on purpose as we are building a huge world and and multiple maps so are trying to automate every aspect of the game for artists to build maps.

Is there at all a way for every single scattered sound in the playlist to keep its position in the world until it gets destroyed? Instead of following the player?

Currently the way the scatterer instrument works is that it will spawn playlist entries in random locations in a sphere around the event emitter and stay in that location in relation to the event emitter. So if the event emitter moves, so does the spawned playlist entry.

There isn’t an option at the moment that will keep the spawned playlist entry in place in relation to the game world. This does seem like a nice feature to have so we’ve added it to our tracker as a feature request.

In the meantime, you can create a workaround by setting the event instance to be created and released but manually setting the 3D attributes so it stays in place in the game world. Imagine it like dropping breadcrumbs except its event instances. You can utilize the event’s cooldown property to prevent too many event instances spawning at once if you need.

Hey Richard thanks again for the response!

Relayed that info to the dev, they said thanks and it just isn’t entirely clear from a code perspective what that would look like and is there a code example for how that would look?

Also is there an ETA on the warning fix?

Thanks so much for your time Richard!

Steve

Hi
I’m reviving this thread cause I’m seeing this log and it sounds like this is exactly my problem.
I have a scatter instrument with quite some samples and some automation to simulate a crowd. And It spams these warnings frequently.

What do you suggest? Telling from what was discussed above: Might it help to just break the Event apart into several events?

I’m using FMOD 2.01.11.

Cheers
Dominik

Edit:
I just tested using Live Update. It’s the “Footsteps”-instrument that causes the warnings. Whenever I delete that one the warnings go away immediately. If I delete any other instrument, nothing happens.
Oddly enough this is the least exciting layer. It just contains 10 footstep samples :confused:
Does this make any sense to you?

You would basically be passing the 3D attributes of the listener to the created instance at the time it’s instantiated and immediately release it (making sure the actual event has a natural end). This way it would lock in place where the listener used to be.

We don’t have an estimated time for when this bug will be fixed.

There is no need to break this event down into several events - the warning being logged is benign and won’t affect actual playback during gameplay in any noticable way. A future update will fix the warnings being logged.