SetDSPBufferSize question for Unity


(Anthony Litton) #1

I am using FMOD Studio and FMOD Studio Integration 1.06.10, with Unity 5.2.

I am finding on iOS that there is some lag. It’s not terrible, but I would like to experiment with changing the buffer size to see if it can be improved.

I’ve read the documentation here: http://www.fmod.org/documentation/#content/generated/FMOD_System_SetDSPBufferSize.html

And read through many answers on this site, but I cannot figure out how and where to actually implement this. I am a self taught/not great coder, and this has defeated me. Nothing seems to work.

A simple code snippet would be a huge gift.

Thanks!


(Nicholas Wilcox) #2

A safer option that may reduce latency is to move FMOD_StudioSystem to after the “Default Time” in the Script Execution Order settings.

But editing FMOD_StudioSystem.cs and inserting this after line 280

    ERRCHECK(sys.setDSPBufferSize(256, 4));

will change DSP buffer size.


(Anthony Litton) #3

Thank you!


(Laurent) #4

Hello Nicholas,

Thanks for your answer but could you please tell me how to do that in FMOD Studio Unity Integration 1.07.06 ? FMOD_StudioSystem.cs doesn’t seem to be used anymore.

Thanks,

Laurent


(Nicholas Wilcox) #5

Assets/Plugins/FMOD/RuntimeManager.cs on line 201 add

lowlevelSystem.setDSPBufferSize(256, 4);


(Laurent) #6

Great, thanks!


(Alireza) #7

How can I change buffersize in FMOD Studio Unity Integration 1.09.06 ? I try to set it by RuntimeManager.LowLevelSystem.setBufferSize but nothing change. it is on default values like before I mean 1024 and 4. I want to change it to 512 and 2.