SetParameter() With Fixed Fps

Hello people,
we have a really big problem at the moment and maybe there is already a way to fix this or something we overread in the documentation.
You can hear the problem in the following videos. Please hear the sound of the cars engine. We use a 3D Timeline in FMOD Studio and use the cars engine rpm to drive the current pitch. In the first video the frames per second are unlocked and you get a wobbly sound, in the second video I have the fps locked to 60 and the problem does not exist anymore. You can see the FPS counter on the top left. The PhysX FPS are always locked to 240hz but putting the “AudioComponent->SetParameter();” calls inside of the asnyc physicstick doesn’t change anything.

Is it possible to set a parameter in FMOD with a fixed fps except for locking the normal fps?

Unlocked FPS → Engine sound is wobbly

Locked FPS → Engine sound is stable

Here is the Event in FMOD for this paticular Car. The nested event contains just looped samples that blend according to the RPM with root pitch.

Here is the code we call in EventTick:

if (EngineAudioComponent != nullptr)
EngineAudioComponent->SetParameter(“RPM”, MappedRpm);
EngineAudioComponent->SetParameter(“AEMSAccel”, AEMSAccelVol);
EngineAudioComponent->SetParameter(“AEMSDecel”, AEMSDecelVol);
EngineAudioComponent->SetParameter(“GinAccel”, GinsuAccelVol);
EngineAudioComponent->SetParameter(“GinDecel”, GinsuDecelVol);

Unreal Engine 4.27 (custom build)

Best regards

I have not been able to reproduce this issue- how are you modifying pitch? Are you using the Autopitch Modulator like in our car engine examples or are you using a Pitch Shifter DSP?
What version of FMOD are you using, and does this issue occur in the UE Editor as well?

Ok I was able to narrow it down. You are right, it is not the autopitch of FMOD, it is the Plugin Audiomotors.

Into the plugin is a RPM value fed so the plugin can choose the correct grain (its a granular synth) to play back at runtime. additionally the plugins “transpose” parameters automated and used to align the synth with the looped samples in FMOD. When muting the plugin the problem does not exist (or at least it is not too apparent), but when only using the plugin without the looped samples the problem is really obvious.
Do you have any experience with it or know where the problem could be? I know that LeSound support is most often extremely slow and it happened to be not really helpful to me.

Best regards.

I am using the latest FMOD version and yes, it happens inside UE4, in PIE, Standalone and a packaged build.

Capping the engines fps to any value produces a stable sound but i cannot guarantee this on every consumers hardware.

Apparently I am using Fmod 2.02.04

Thank you for confirming, it does sound like the issue is with the Audio Motors plugin. There are a number of things that could result in unwanted pitch shifting, such as a varying sample rate, or perhaps something in the pitch shifting algorithm lerping between parameter values unevenly. Unfortunately we have no way of knowing what the inner workings of 3rd party plugins could be, so this is just speculation.
The best thing to do would be to contact the plugin maintainer with this issue.