Sound issues in build and FMODStudioSettings.asset unintentionally changing


I am working on Mac OS Monterely 12.6 with Unity 2021.3.27, FMOD Studio 2.02.04, and FMOD Unity Integration 2.02.15. I recently noticed that these versions do not match, though I am uncertain if this could be causing my issues.

For a while now, FMOD has been causing problems in our project, particularly when we had the builds file in the same project as the game. However, since we moved the builds to a separate folder, the system has been operating much more smoothly. Currently, we are using “Source Type: FMOD Studio Project / Streaming Assets”, with the file path set to “…/game-fmod/game-fmod.fspro”.

Despite these improvements, I’ve encountered two instances where I made a build via the terminal (without running Unity Editor), and the resulting game had no sound.

The following day, I experienced another issue: the file Assets/Plugins/FMOD/Resources/FMODStudioSettings.asset had changed, even though I hadn’t altered anything. This change resets all settings, which happens from time to time, sometimes when merging or switching branches. The usual fix involves discarding the changes in Git and restarting Unity, which typically resolves the issue.

Since I’m developing on a Mac, but building for Windows, after each build, I always have to start my PC, update on Steam, and test to make sure everything is working properly, which I’d rather not have to do. I made a build for Mac via the editor just before, and everything was working there.

My main questions are, how can I ensure that the sound will always function properly in a build and why does the FMODStudioSettings.asset file keep changing unintentionally?

Any help would be greatly appreciated.

EDIT: After reviewing unity Player.log, i found this error which seemed important. THe bus Music exists and works in Unity editor.

BusNotFoundException: [FMOD] Bus not found 'bus:/Music'
  at FMODUnity.RuntimeManager.GetBus (System.String path) [0x00018] in <92a008654efd4dacb1844ff7acb7559e>:0 
  at _Game.Scripts.BlueGoo.Audio.CustomStudioEventEmitter.Start () [0x00008] in <c02a6407f14c4b269e32aed3e4f7adee>:0 

BusNotFoundException: [FMOD] Bus not found 'bus:/Music'
  at FMODUnity.RuntimeManager.GetBus (System.String path) [0x00018] in <92a008654efd4dacb1844ff7acb7559e>:0 
  at BlueGoo.UI.Settings.AudioSettings.Start () [0x00000] in <c02a6407f14c4b269e32aed3e4f7adee>:0 

EDIT2: I also found this as the first error in the log

EventNotFoundException: [FMOD] Event not found: {d8b35fb1-8c6d-4c69-a7d6-f8703e2d0fc9}

And in the editor, this is the first fmod event, main menu music that is playing. So it seems the fmod banks aren’t in the build. Any idea why this might happen? It has worked for a long time in builds, but this has happened once before, and I’m not really sure what I did to fix it then.

Thank you!


Thank you for the detailed explanation.

As you mentioned, you are using the Command line to build the Unity Project for Windows. The command has the option of adding a log file which would be a good place to confirm there are no build issues: Unity Documentation | Working in Unity - Unity Editor Command Line Arguments. However, it may be related to the FMODStudioSettings.asset getting reset and influencing the build options. Do you know if it is the same issue every time that is impacting the Windows build or are you noticing the errors are changing? Any past build logs you have that contain any information would be really useful. It is hard to always be 100% sure that a build will be successful, unfortunately.

This is a known issue that we are currently looking into. If there is an update I will let you know.

There were no actual build issues, but the issue was due to FMODStudioSettings.asset changing, and resetting during build time, causing sound to not work. We solved it by making a copy of the file in a special folder, and during build time, I run a script that copied the file into the correct location. This worked.

We also now put the FMODStudioSettings.asset in .gitignore, but with the effect that all new devs have to configure (or copy) the settings.


1 Like


Good to hear it is working. It is important for the FMODStudioSettings.asset to be included in the Source Control, however, it is a workaround for the time being while we continue to investigate the issue.

Once there are updates I will post them here.