Sound prioritization broken after swithing to Resonance audio listener and sources


(Rune Skovbo Johansen) #1

I recently switched to using Resonance audio listener and sources for 3D audio sfx in my game. After this, some sounds stop playing when other sounds are playing that are both beyond the maximum sound distance AND lower priority too.

I don’t know if Resonance audio sources don’t give FMOD currect information about how loud sounds are so that FMOD can correctly prioritize the loudest ones? In any case, the sound in my game is completely broken with loud sounds cutting out all the time when other much quieter sounds (or even silence due to being beyond max distance) are playing. I’m not sure what do to.

I’m using FMOD Studio 1.10.05 with the Unity integration.


(Cameron Baron) #2

When determining audibility for Event stealing only the master track volume and master track DSPs that expose the overall gain parameter are considered.

It looks like the parameter was not added to the plugin so at the moment no, resonance audio attenuation will not be taken into account when doing stealing.

We have raised this as a task and will work with Google to get this fixed.


(Rune Skovbo Johansen) #3

Thank you. Do you by any chance know if the same issue also affects these other FMOD Studio plug-ins: Oculus Spatializer by Facebook/Oculus and/or Steam Audio by Valve? Or will FMOD correctly take attenuation into account when those are used?


(Cameron Baron) #4

It looks like these other plugins have the same issue.
Thanks for bringing this to our attention, we will be working with the developers to resolve this.