Spatializer effect pans too aggressively

When I add the Spatializer effect to an event in FMOD Studio and play the event in my game, the panning it produces seems far too strong.

If I’m a short distance away from an object and turn my camera by 45 degrees, the pan goes hard to the side – if I look right, it feels like the sound is coming directly from my left side. This matches how the 3D Preview sounds in FMOD Studio.

This doesn’t happen when I use the 3D Object Spatializer effect – turning my camera 45 degrees produces the result I’d expect, where the sound is quieter in my right ear, but not almost completely silent.

I’d like to avoid that effect, though, given how it messes with the signal chain. Also, unlike the regular Spatializer, it lacks the “2D Pan Mix” settings that let you control the spatializer’s mix.

I have attached a recording of the problem. The sphere is playing pink noise. For the first half of the video, I have the Spatializer effect active. I then switch to the 3D Object Spatializer effect for the second half.

From my real-world experience, sounds at a moderate distance just don’t sound this heavily panned – even in environments with almost no reverb, like an open field.

I did notice that it sounds a lot more correct if I just increase the 2D Pan Mix knob a little. The result is a lot closer to what the 3D Object Spatializer sounds like. Setting “Envelopment” to User mode and then increasing the Min Extent dial also makes it sounds much more like what I’d expect.

Is this just how the Spatializer is meant to work? I think I’ve wound up solving my original problem while writing this post, but I’d like to know if either of these fixes are common practice!

1 Like

Ah, perhaps I’ve just figured out what I was misunderstanding…


I’m wearing headphones, so the left and right channels play straight into my ears. But the preview here clearly shows that the L and R speakers are positioned 30 degrees to either side of the listener.

This makes plenty of sense if you’re using speakers to listen to my game – the audio should pan all the way left for an audio source that’s on the left side of the screen.

Do I need to add an automation to let the player switch between “speaker mode” and “headphone mode”? The audio makes a lot more sense when I reduce the “Extent” setting on the master bus to around 120 degrees.

Edit: And here’s the punchline: I had accidentally set the project’s “Surround speaker mode” setting to Surround 5.1 instead of Headphones. Case closed :slight_smile:


Hopefully this’ll help someone else who made the same mistake as I did, at least!


I’m glad to hear you were able to identify and fix the cause of the issue you were experiencing.

1 Like