Steam Audio + FMOD ceases to work when loading new scene


(Felix Hansson) #1

I’ve made an issue on this at Steam Audio’s Github also https://github.com/ValveSoftware/steam-audio/issues/70:

"When using FMOD’s audio engine with Steam Audio in Unity it will initially work in the Editor but when loading a scene it will stop working, even when I reload the current scene. When using Unity’s audio engine with Steam Audio it will keep on working leading me to the conclusion that something is wrong with the FMOD implementation. Furthermore, if I Live-Connect with FMOD Studio and Bypass the Steam Audio Spatializer the sound will play normally.

I looked into the Steam Audio code for FMOD integration a little but couldn’t really find anything conclusive. The two ideas I have are that either something is wrong Steam Audio code for FMOD, or that FMOD somehow drops the plugin or connection when a scene closes down and the Steam Audio Manager is destroyed and then when a new scene with a Steam Audio Manager is loaded FMOD simply ignores it.

I have a test project to demonstrate the problem and can provide it if anyone is interested, with all the plugins etc its a bit big to upload here directly."

Thought I’d ask here as well for input on my latter suspicion, is there anyway you could force FMOD to reload plugins or something similar?

Forgot to mentions this at the Github issue but I’m running Win10 64-bit if that makes any difference.


(Cameron Baron) #2

If you would like to send us the project or link to the project, I can take a look at it for you. You can send it to support@fmod.com if you like.


(Felix Hansson) #3

Hi there, mail sent. The project is uploaded here: https://github.com/FelixHansson/SteamAudioFMODTest


(Cameron Baron) #4

Thanks very much for the project, it was very helpful.

From what I can see, the Steam Audio Manager Settings gameObject gets destroyed and re-initialized between scenes. By adding DontDestroyOnLoad(gameObject) after the initialize, the problem seems to go away, more testing would be needed to make sure this doesn’t cause any issues.

Valve own the Steam integration so it will be up to them to make the changes, I have added a comment to the github issue you raised.


(Felix Hansson) #5

I tried what you did with DontDestroyOnLoad and it seems to work when changing scenes, I made a copy of the first but removed on of the boxes in the middle and the sound did change accordingly. Likewise I’m not sure if this causes any problems. It is somewhat weird since you need a Steam Audio Manager Settings in every scene to build the scene data and you can have scene specific settings, so something feels off.

I’ll keep looking into that on Github, thanks for the help.