Transition region with Stopping event bug?

Hello, the situation is like this, when I make a Transition region set to Marker with Event Stopping condition it has roughly half a second delay before it skips to Marker.
I tried with the Transition timeline set to zero but it`s still there. Is there a way to turn off this delay or is it a bug?

This delay is due to how often the FMOD system updates. Transitions of any kind will not happen immediately. You could possibly mitigate this in game code by calling Studio::System::update() after stopping the event.

Half a second is… a lot!
From what I’ve tested, the long delay comes from the stopping process rather than the transition itself. Why don’t you trigger your transition by something else than the event state?

Well, i dunno. I was happy about this new feature because it would be great to have one event for movement and stop of some sound instead of having two events triggered separatly from game. So i was trying it out and ran into this obstacle.

I don’t really find the use of what you describe. You stop your event but you still expect it to go to another region before dying? Could you explain your event purpose and contain?

Well I wanted to use it for looping sounds that stop when player wants it.
For example imagine a movement of a construction crane that you rotate, while moving you play a loop but when there is no more input from a player you stop the crane and also the sound. Well on that stop you could play a sound effect for a stop that masks be cut in sound. Or an elevator movement…

The best design for what you describe (in my humble opinion), is the following:
A multi-instrument with the main sound, async and loop buttons checked, with a sustain point snapped right at the end of the instrument, and either a finishing sound right after that, or an AHDSR modulation on the main instrument volume (to set the release). Instead of stopping the event, you do a “key off” (and the event will dye by itself).
I say multi-instrument because single-instrument seems to have a bug (it cuts even without the cut button checked). But it also could be any other instrument type (I use a scattered instrument for a footsteps loop, for instance).

Thanks for the tip about the single instrument. You are right, that is the normal way to go, to my shame I never implemented sustain point in my workflow. I will correct that.
This use that Im talking about would give a bit more flex with transition crossfades, maybe Im wrong.

I was just trying with your method. That’s true it should work well but the delay is too long. Did you try the Studio::System::update() method described by @richard_simms right after the stop? However I doubt it will work, since there’s already a noticeable delay within FMOD Studio…

“Half a second”

Do you have any assets in the event that are set to streaming?

It might be possible your assets are set to streaming that could be causing such a delay. You can set these assets to not streaming and also call loadSampleData on the event to preload the assets if that helps.

Otherwise, as an extreme measure, you could try adjusting the studioupdateperiod property of the advance settings when initializing the FMOD Studio system.