Unable to load fmod plugin after packaging


I recently added Steam Audio (beta 17) to my FMOD project (1.10.15) and it works fine in the Editor (UE 4.22).
I added the plugin to fmod’s ue4 project settings (phonon_fmod) and also added the libs (phonon, phonon_fmod) + plugins.txt to the platform folders of the engine which is used for building.

I tried different variations in the plugins.txt:

phonon (<— I tried with and without, not sure if this lib needs to be added)

(for linux I had to compile the plugin for linux and prefix the libs with ‘lib’ in plugins.txt)

When starting the game (Win 10) this is logged; there is no sound output from FMOD:

[2019.08.25-10.26.27:335][  0]LogFMOD: Warning: f:\jk\workspace\1.10_UE4.22_Win64\studio_api\src\fmod_effect.cpp(189) - Missing DSP plugin 'Steam Audio Spatializer'

[2019.08.25-10.26.27:340][  0]LogFMOD: Error: f:\jk\workspace\1.10_UE4.22_Win64\studio_api\src\fmod_runtime_manager.cpp(1315) - DSP plugin returned an error, bank will not load properly.

[2019.08.25-10.26.27:345][  0]LogFMOD: Warning: Failed to bank: ../../../TO/Content/FMOD/Desktop/Gamesounds.bank (A requested output, dsp unit type or codec was not available.)

Is there any mistake on my side? Otherwise I guess Steam Audio is broken for ue4.
I could not test on fmod 2 since adding a Steam Audio Spatializer just freezes that fmod version.


It sounds like you have it set up correct, in the logs it should tell you what plugins are being loaded just before the banks get loaded. Does yours say anything here?


LogFMOD: Creating runtime Studio System
LogFMOD: Default sample rate = 48000
LogFMOD: System sample rate = 48000
LogFMOD: Matching system sample rate 48000
LogFMOD: Loading plugin 'resonanceaudio'

I think they aren’t loaded…

A full log:

I would double check the steps for adding plugins in the docs: https://fmod.com/resources/documentation-ue4?version=2.0&page=plugins.html