Unity doesn't find newly added events in Fmod after updatign Unity version

Hi all,

The devs I’m working with have recently switched the project into a newer version of unity: 2020.3.8f1.

At first I didn’t notice any anomaly, fmod and Unity would talk to each other and the audio would run smoothly. However today I tried to add a new event and noticed that unity would not recognise the event path. I did some testing and realised that no new event is recognised by Unity.

I create a new event, assign it to master bank (the only in use so far) and build the project, but unity doesn’t detect any changes. It also happens if I modify an existing event and press on build.
Strangely enough it does pick up changes to existing events if i do them in Live Update.

The fmod version I’m using is 2.00.10.

Any help is much appreciated!

Thanks in advance

When you updated to a new version of Unity, did you also update the version of the FMOD Studio Unity integration used by your game?

Update. I have just updated the the Unity integration but result hasn’t changed

Ok, issue solved. It didn’t have anything to do with fmod/unity version. it was an issue with file management. Thanks a lo Joseph