Unity does not find FMOD events

Hello, I am new here, but I have a question. Recently, I integrated FMOD into one of my Unity projects and it worked perfectly fine, but yesterday I wanted to switch to a different FMOD project and everything stopped working. Unity tells me that it could not find the event with every event in the FMOD project.

What I did up until now:
-Switched Bank import to new project (duh)
-rebuilt all banks
-tried importing the banks from different directories
-tried making events with no folder hierarchy
-Preloading all events
-completely reimporting FMOD in the project
-deleted the “fmodstudiocache.asset” files

Things I found out:
-the FMOD package always shows “Import” as an option, even though it should change to “Uninstall” if I am thinking correctly
-Events are shown in the Event Browser, but I can not listen to them through it
-if I change back to the old project, all the sounds work again

It would be marvelous if someone could help me out with this.

Thanks in advance!


To clarify, have you switched from one FMOD Studio project with it’s own set of events, buses, banks, etc., to another FMOD Studio project with a different set of events, buses and banks?

Yeah, am I not supposed to do that? ^^"

You can do that, but all existing references to the old events, banks and buses in your Unity project will break, event if they share the same path/name. You may be able to update some references using FMOD → Update Event References.

As far as I’m aware, there is never an “Uninstall” option - if you want to uninstall the FMOD Studio package, you need to remove it from the ./Assets/Plugins folder.

Are the new project’s events shown in the event browser, or the old project’s events?

Hey, I forgot to mention, that I already tried to update the Event References, but sadly it does not find any References which have to be updated.

The events shown in the event browser are the new ones.

And to be clear, as you said in your initial post, you still can’t audition them or play them in a scene?

If not, can I get you to provide your Unity, FMOD Studio, and FMOD for Unity version numbers? Also, if possible, can I get you to upload packaged versions of your old and new FMOD Studio projects to your profile so I can attempt to reproduce the issue? You can do so via the “Uploads” tab in your FMOD Profile.


yes, i still can not play or audition them in a scene.

My Unity Version is 2021.3.16f1, my FMOD Studio Version is 2.02.13 and my FMOD for Unity Version is 2.02.13.

I am going to upload the packaged versions right away.

Thank you so much in advance!

PS: I have to wait for approval of the project

Second Edit: Both Files are uploaded

Thanks for uploading your projects. I suspect the issue may be that you have specified an output directory for built banks in your new project, but you haven’t in your old project. When using the “FMOD Studio Project” source type in Unity, the FMOD Unity integration only looks for the ./Build folder that shares the same directory as your .fspro file - it doesn’t check whether you’ve set a specific “built banks output directory” in Edit → Preferences → Build.

Try either removing the path from your built banks output directory and rebuilding your banks, or changing your “Source Type” in Unity to one of the platform build options and setting “Build Path” in Unity to match the built banks output directory, and seeing whether that resolves the issue.