VRTK, FMOD, Unity 2019.1.14


I set up a very simple project with Unity and VRTK which works great.

Then, when I added FMOD, I can’t start my game anymore, Unity displays the following message (in-game) “Display 1 No cameras rendering”, when I remove FMOD plugin, my game works again without problems.

The problem can be found just by trying to run an example with the FMOD unity integration package (linked to a project).

I tried to follow FMOD tutorial at this link and add the FMOD Studio Listener to the main camera into the VRSimulator MainCamera but it doesn’t help.

Has someone encounter the problem and fixed it ?
Or have any tips about where the problem is coming from ?

Thank you in advance for your answers !

PS : I also tried to reorder script execution order to put FMOD in last position. And I am developing on Windows 10, with Unity 2019.1.14f1 and using FMOD 2.00.06 integration.

I quickly tried out VRTK + FMOD 2.00.06. + Unity 2019.1.14f1 and it works without any problems: https://streamable.com/d9zow

Are you getting any errors in the console?

Nevermind, I didn’t see that the Unity integration version should match with the FMOD one, this is what was causing my problem (I was using FMOD 2.00.05 with integration 2.00.06).

Anyway, thanks a lot for your help… :sweat_smile:

1 Like