'A socket error occurred' on startup in 4.9.2

Hi,

I tried to test multiplayer features in my game and get this error:

gFMOD:Error: ‘StudioSystem[EFMODSystemContext::Runtime]->update()’ returned ‘A socket error occurred. This is a catch-all for socket-related errors not listed elsewhere.’

in an endless loop when I start the game. It didn’t occur earlier, but I didn’t really change anything… It occurs in other 4.9 projects as well.

I found this question: http://www.fmod.org/questions/question/fmod-studio-integration-liveupdate-cannot-connect-with-unity-5-beta/ about the same error in Unity, but

Do you have any idea what could cause this error?

I’m using the current version 1.07.02 of the FMOD plugin.

If you are running client and server at the same time the live update won’t be able to create a socket for live update. If you don’t have a separate client/server, you might still get the error if some other program is holding on to the same port that FMOD tries to use.

There are a few things you can do:

  • Disable live update in the settings
  • Add -noliveupdate or -nosound to the command line to disable either live update or the entire sound system.
  • If the server is dedicated, it should already be running with the equivalent of -nosound so that should just work.
  • You can tweak whether live update is enabled by changing ini files manually, for example if you are already changing ini file settings by hand.
1 Like