BUG: Labeled Parameter Automations ignoring Conditionals

FMOD Version 2.01.09 and 2.01.10
I wanted to attach a project as well, but it won’t let me. If you want a testproject with the setup already done let me know.

There is a serious Bug regarding labeled parameter automation, resp. if a labeled parameter gets atuomated by ANY other parameter.

This only gets obvious when trying to base e.g. a transition conditon on the automated labeled parameter.
When trying to make Transitions conditionally based on the Controlled Parameter, it would work in 99% of the cases, but some values just wont trigger the transition. i tried various solutions, like re-making the Controlled Parameter etc. but nothing worked.

If I would MOVE the not working labels to other values they would work again, but other Labels/values that move onto the newly free’d position will then instead NO LONGER work.

Meaning the causing trouble might be the float value itself or the automation mapping. so my best guess would be there is some floating point issue or some error when jumping between these discrete values that causes this.

The float values of a controlled labeled parameter that never work are:
7, 14, 15, 28, 29, 30 - as far as i have tested (i stopped around value 45 with testing)

and it does not even matter how i automate the labeled parameter, it’s just THAT i automate them in any way, it doesnt even matter with what i automate it.

(Not to mention, it is a pain to map those things in such a small automation window in the parameter editor when you use (like me) two big labeled parameters that both have around 50 entries.)

Steps to reproduce:

  • empty project
  • create new event EVENT with timeline
  • create destination marker somewhere
  • create transition region + loop in same length prior to destination marker
  • create labeled param TESTPARAM with 45 entries (global) (EDIT after FMOD response: for ppl that read this later) - it needs to have values from 0 - 45, so 46 entries to recreate the bug)
  • create some other global param
  • add TESTPARAM sheet to EVENT
  • add conditional to transition region for the label with VALUE 7 (or 14, 15, 28, 29, 30)
  • add automation to TESTPARAM, select other param, add curve
  • set e.g. that ALL possible values take the Label with value 7
  • start event, let playhead move into transition region
  • observe that playhead keeps playing in loop, although conditional is met (ALSO: conditional is highlighted, funny enough)

Took me quite some time to figure this out…
looking forward to a fix, thank you

Thanks for reporting this issue.

According to our records, this bug was fixed in version 2.01.08, so the fact that you’re encountering it in later versions means we must have missed certain reproduction cases. I’ve reopened the issue in our bug tracker.

Unfortunately, I haven’t been able to reproduce this issue based on your description; when I test here, the float values you call out can be used to trigger instruments without problems. There must therefore be some detail of your reproduction steps that I’ve misunderstood, or some feature of my test setup that differs from yours.

Could you send us the test project that you mentioned? You should be able to upload it in the uploads tab of your profile on this website. (Note that you must have registered a project with us to upload files.)

Hello! I uploaded it to my Upload section.


Please let me know if you can open it.

I just retried making a fresh project in 2.01.09 with my steps and i can reproduce the bug.
BUT i noticed the labeled parameter needs to have 46 (!) entries, sorry. so values from 0 - 45.
Also works if Parameter 1 has 49, 51 or 52 entries.

It couldn’t be related to multiple versions of FMOD being simultaneously installed…? (Currently i have 2.01.09 and 2.01.07 installed)

Parameter 1 (global) is automated by Parameter 2 (also global)
→ Parameter 1 takes always Value H (7) no matter what value Parameter 2 has
→ Transition Region has conditional that Parameter 1 has to be “Value H”
→ Transition does not happen

OK sry i put the wrong numbers in again for some occasions, Bug is happening if:
Parameter has
highest Value of 45 (46 Entries)
highest Value of 49 (50 Entries)
highest Value of 51 (52 Entries)
highest Value of 52 (53 Entries)