Event not triggering

Very new to this, so sorry for the noob questions.

I am fiddling around with an already created project, replacing assets with my own.
Now all of a sudden, there is an event that isn’t triggering anymore at all when connected with Live Update. Pressing Play in FMOD triggers the sound, and it’s routed correctly all the way to the Master Bus. I have tried the profiler and recorded gameplay, but the event is just not showing up anymore. And I can’t see that any kind of snapshot is active during.

How can I troubleshoot this?

It’s hard to say without seeing the project itself. Have you built the latest banks? Is the event assigned to a bank?

Yeah, the event is assigned to a bank, and the bank has been built.
Any suggestions on how I can troubleshoot this? Because I have followed the routing through all the groups to the master bus. And none of the groups’ faders are affected during gameplay (they are all still up).

You say it doesn’t trigger with Live Update, but does it trigger in game without Live Update? (I guess not)

It does actually trigger before I connect Live Update. But when it is connected, I can’t even see the event triggering in Profiler.
I have tried an older version of my project (before whatever thing I did that disconnected this) and there the event and sound triggers as normal during Live Update. So I have obviously done some mistake somewhere, but I can’t figure out what.

I’ve generally experienced such things when there was a mismatch between the opened fmod project and the built banks used in the game. Try to rebuild the banks with the latest version of the project.