FMOD 2.01 FMODStudioCache.asset importing every time I click Play, and Debug Overlay is always enabled when I start Unity

Hi, I updated our studio’s project from FMOD 2.00.03 to FMOD 2.01.11. Now it seems like I’m stuck with the following 2 issues:

  1. FMODStudioCache.asset is reimported every time I click Play. There seems to be no logical necessity for this, and most people don’t really care for the event browser. Can I turn it off somehow without altering the plugin’s code?
  2. FMOD Debug Overlay is gets re-enabled every time I start unity. Once again, most people on the team other than me and the sound person shouldn’t ever need this.

Can I somehow fix these in a way that’s not going to break stuff and/or make future migrations harder?

Edit: Commenting out the bank refresh on startup seems to fix both, which probably means FMODStudioCache.asset is being recreated every time or something like that. Perhaps that’s the problem that actually needs fixing? How do I go about that?

Regards,
Todor

  1. I have reproduced this in 2.01.11, but this appears to have been fixed in 2.01.12+
  2. I believe this was an issue that was fixed in 2.01.14 and it’s due to the platform settings not saving, which could cause other issues for you later on.

Can you please try updating the FMOD Unity Integration to the latest 2.01 version (2.01.15)?