Fmod Sounds and music droping. Overload?

#1

Using Fmod 1.10.10 with UE4.19

We have some users experiences (and badly after the game releases) that encounters a drop of all the sounds in the game at some point.
Fot some users, the sounds get back later in the game.
Is it due to an overload? How could I debug this? Should I make more banks?

Here is a video of the phenomenon occurring : https://www.twitch.tv/videos/356530980?t=08h00m53s

0 Likes

#2

It is difficult to begin to guess really,

A couple people on the stream thought that the issue occurred when trying to skip over too many ‘bubbles’.
If you are able to reproduce this, you might be able to get some logging information about what is happening, and even better if you can use a debug build to get even more information.

0 Likes

#3

Thanks for your answer.
Skipping bubbles could rarely break the composition of the music, but not the whole sound system. I also added protections to go back to music if a trigger box with a Fmod parameter would be skipped.

You can hear there, that the whole sound system is broken. I’ll investigate, but I was wondering if you could have some clues. I was never able to reproduce this. It happens very randomly.

0 Likes

#4

Unless we can get any sort of logging information from the game, it’s difficult to even start guessing sorry.

0 Likes

#5

I have the same problem, very close to release!!

I’ve just emailed a reasonably details descripion to fmod support, so will report back with any news. Have you got any further with this?

For us, it only seems to take place after 10 minutes or so play.

0 Likes

#6

Hi @holleygray
Did you managed to find a solution? Is the last Fmod version with this fix worked ? : " * Studio API - Fixed fire and forget event instances not releasing when another instance of the same event is active."
I haven’t tried to fix yet, but next week I’ll put my hands in it.
@cameron-fmod, do you have a walkthrough to Log Fmod within an Unreal build? Thanks!

0 Likes

#7

As far as I am aware, this fixed @holleygray’s issue.

As for logging in Unreal, currently you have to edit the integration source code manually.
In the FMODStudioModule.cpp, StartupModule():

Change the FMOD::Debug_Initialize to use FMOD_DEBUG_LEVEL_LOG.

Then you should get more logging in a built game, as long as you are using a debug/development build.

I have added a task to improve this in a future patch, something like a drop down selector in the settings.

1 Like

#8

Hi Tom,

Cameron at fmod was really helpful and we managed to solve the issue. He gave us a solution to fix the problem, which was relating to callbacks and transisions. This worked great and is in our current game build. As we are so close to release we’re reluctant to update the plugin again, so I can’t talk for that, but the solution he gave definitely worked for us, so if that’s been implemented into release it should be fine.

I’d suggest trying the new plugin, and if it doesn’t work, try the solution posted on my error post.

If this doesn’t work either, just get as much info together as you can, try and reproduce the error and send it to the guys at fmod. I’m sure they’ll work it out!

Good luck man, let me know if you need anything else!

2 Likes

#9

Hi @cameron-fmod and @holleygray and thank you for your help.
I still haven’t tried to debug this, but there are two things that comes in my mind :

  • First, the Studio API - Fixed fire and forget event instances not releasing when another instance of the same event is active. is perhaps a solution as in the part of the game the bug is happening, there are a lot of event instances being played.
  • Second, I also have event callbacks in this level, that could be generating the error. And the thing is that I’m also using the newest timeline transitions.

A question for you Cameron is that I can’t see a fix in the Revision concerning Timeline Callbacks and Timeline transitions. Does this problem has been fixed and how?
Shall I disable timeline callbacks?

Thanks!

0 Likes

#10

I’m not sure what fix you are referring to for Callbacks and Transitions. If this is a different issue I would suggest creating a new thread.

0 Likes

#11

Hey @cameron-fmod and thanks for the answer.
I’m referring to this answer you gave on another thread : Thread

0 Likes

#12

It looks like that was fixed in v1.10.11 as well, but for some reason did not have a revision.txt entry.

0 Likes