FMOD Studio won't use any audio output except "Built In Speakers" - Mac

I’m not super experienced with FMOD, so it’s possible I’m missing something obvious (I sincerely hope this is the case!)

I probably haven’t opened FMOD since April, but I don’t recall ever having this problem before today. No matter how I set the Output Device in the Preferences, I only hear sound from the Built-In Speakers on my macbook pro. I haven’t tried on other systems/computers (I don’t have any others available at the moment).

If I set the output device to “No Sound” it will indeed stop outputting sound, but if I use any of the “Core Audio” devices, it will only play through the built in speakers. Changing the default system device also has no effect on FMOD - I only get sound from the speakers. I’m a little baffled …

Macbook Pro, M1, Ventura 13.4, FMOD v2.02.2019

Hi,

Unfortunately, I was not able to reproduce the issue. However, our M1 device is using Sonoma.

Would it be possible to get a screenshot of your FMOD Studio preferences:

There is a known issue with Studio where the Output Device will not update with the system output device until you open the FMOD Studio preferences.

thanks for the response, Connor.

Here’s a screenshot of my output device settings:

and here’s a short video indicating what’s going on. I hope its clear - I know it’s a little hard to tell where sound is coming from on the phone audio:

https://www.dropbox.com/scl/fi/3vnxvox7xqqhe6tea5fmk/2023-11-28-12.33.06.mp4?rlkey=otv99tddoknz0l7dfce4r4dus&dl=0

1 Like

Any thoughts/updates? this is a truly debilitating issue for me.

i’ve tried trashing the “application support” folder, re-installing fmod - no change

1 Like

Hi,

If you change the system output to match what is set in the FMOD Preferences like so:


Do you still experience the issue?

I found if I have the system output different from what is selected in the FMOD Studio preferences it will play out of the system option. Let me know if that is what you are finding as well