FMOD Unity, Multiple Cameras, Forward renderer, Spatializer

I have tried everything I can think of but I can’t get 3d Spatializer to work properly in my Unity Game? I have an FMOD Studio listener on the main camera (there are two other cameras in the scene dealing with other drawing stuff).

I am using the “PlayOneShotAttached” function in the runtime manager, and the spatializer is set to log with 1K distance, but no matter how far I am away the sound is still played full volume?

Anything obvious you think I might have missed?


A quick checklist:

  • What versions of FMOD Studio and FMOD For Unity are you using?
  • Have you set an attenuation object on the FMOD Studio Listener?
  • You’ve said the Spatializer’s distance is set to 1k - I assume you mean the max distance? What are the exact settings for min and max distance that you’re using?
  • Is it possible that you’re passing the wrong GameObject to RuntimeManager.PlayOneShotAttached? If it’s the correct GameObject, is the GameObject within the Spatializer’s minimum distance?
  • Have you made any other changes to the Spatializer settings besides the Attenuation Curve i.e. Envelopment, 2D Pan Mix, Distance Override?

Hi There,

thank you for the reply sorry for the delay in response.

I have tried a few different things to get this sorted but the sound still appears to play full volume when I am 2k units away…

I am using the standard curve, I have a distance override set to 1.00 and 500.

I have tried both one shot attached:

 EventInstance gunshot = RuntimeManager.CreateInstance(gunSound);
 gunshot.set3DAttributes(new FMOD.ATTRIBUTES_3D());
 RuntimeManager.AttachInstanceToGameObject(gunshot, barrelBase);

And like this

 RuntimeManager.PlayOneShotAttached(soundPath, attachedObject);

The listener object is set to the main player camera and the attenuation object is set to the game object that the player is moving on. Envelopment is set to Auto and I haven’t applied any other settings

The FMOD version is 2.02.12 64-bit with unity version 2022.3.6f1


Thanks for the additional info. The usual culprit for this kind of issue would either be an incorrectly configured signal chain or Spatializer settings for the event, or that the listener/event instance is being provided with incorrect 3D attributes. However, unfortunately I haven’t been able to reproduce the issue based on the circumstances you’ve described.

So that I can take a closer look and hopefully diagnose the issue, can I get you to upload your Unity and FMOD Studio projects, or a stripped down version of each where you can consistently reproduce the issue, to the Uploads tab of your FMOD User Profile?

Hi Louis,

Thank you for your response I really appreciate it. There were a few things in play as you rightly described the 3d Attributes weren’t correct, my 3D parameters in FMod studio were incorrect. I had to park this project for a while but when I came back to it, removed the listener objects from the scene and fixed the mentioned issues everything is now working as expected!

Thanks again for your help!

1 Like

No problem, I’m happy to hear you managed to resolve the issue!