Google Resonance 3D effect not present

Hello. I’ve recently starting using Google Resonance in an FMOD project.

I’ve noticed that the 3D effect of the sounds in the environment are more or less not present. The occlusion effect is very present, but there’s no real panning going on. The effect is mirrored in the 3D panner window in FMOD where moving the location around will have an effect on the amplitude and filtering, but not the panning.

In Unity under the relevant event emitter component the event is listed as 2D as well. As far as I can understand, the only real difference in making a 2D versus a 3D event in FMOD is whether or not the master track has got a spatializer on it, which it of course does, but now it’s just the Resonance variant, as in the Resonance Audio Source, and the spatializer on the master bus.

I remember, before using FMOD, trying out Resonance directly with Unity’s own sound engine and I seem to recall the 3D effect was present then.

Any idea what I’m doing wrong here?

I’m using Unity v. 2019.3.1f1 and FMOD v. 2.00.07.

Thanks in advance.

The event will show up as 2D in the event browser because it does not contain a FMOD spatializer, the check is basic and does not take third party spatializers into account.

It sounds like you have it set up right, but just in case you aren’t already, using the resonance docs may also help:

In my own testing, the resonance plugin has been working without any issues. If you can provide a video or project that reproduces the issue you mention, I can take a look at it to get a better understanding.

Here’s a short video of me reproducing the issue in a new FMOD project.

As you can hear, the panning works fine with FMOD’s built in spatializer, but there’s no 3D panning when using the Google Resonance spatializer. For what it’s worth, I asked a friend to try as well, and he had the same issue.

Not 100% sure if this is a fix, or more like a check.
In my Google Resonance projects, I’ve had the master bus output set to stereo, rather than surround. Your video also shows that the input of the master bus is surround, maybe put that to stereo too. Usually I also set the input of the event master to mono.

That doesn’t seem to be the issue. In the project where I first noticed the missing panning, I had it set up exactly as you describe. I just tested it again to be sure, but no result.
Thanks though.

If you can supply us with the project that reproduces the issue (you can upload it to we can take a look at that.

When I click the link it says “token is not valid” and the “please wait…” section doesn’t change to anything else.

Is it still giving you the same error/message?

I had to sign in and out for some reason. It only takes me to the profile update page, no upload page. I thought I had to use the projects section to upload a project, so I accidentally created something that is in need of approval, so please disregard and delete that.

Thanks for the heads up, try it again now.

Now it works. I’ve uploaded another new project where the 3D panning is still missing. Just a simple small one. Thank you.

Thanks Marc, looking into it now.

Any findings?

For some reason it didn’t occur to me to try a previous version of FMOD, which I just now did. I tried versions 2.00.03 to 2.00.08. The panning seems to work on versions 2.00.06 and down. At least for me.

It looks like this is a bug in Resonance on Mac and iPhone, due to some math inaccuracies, this has been fixed for the next release due to be release at the beginning on April.

Thank you for looking into it. I’ll be using an earlier version of FMOD until then.