Unable to integrate FMOD with Resonance audio into Unity

Hi everyone.
I know I am a complete noob, but for the love of god, please help me. I´ve been trying to integrate FMOD using Resonance audio into Unity project, just to “play around” with it, to actually hear the difference between this and the default FMOD spatialiser. The problem goes like this: I create a new project in Unity and FMOD. I build banks and everything. I integrate FMOD into Unity project. Everything seems fine, the sounds play. BUT - when I change/place Resonance audio listener/source anywhere in FMOD project (master bus, master track of an event…), Unity project gets completely silent, all the sounds gone.
I tried googling stuff up. I found a web saying I should first select resonance audio plugin as spatialiser in unity project settings. Not working, because there is no resonance audio plugin to choose from. I tried to download and install custom asset (resonance audio by itself) into Unity project. It works fine in the demo scene until the moment I want to integrate FMOD into this project. Resonance audio completely disapears from unity project settings and there is “none” selectable.
Please, please, what am I doing wrong? What am I not seeing? I repeat - I am no programmer, just a sound designer who wanted to test resonance audio spatial posibilities.

1 Like


What version of FMOD are you using?

So the issue is the FMOD integration needs to know about the resonance audio plugin which is outlined here: Unity Integration | Plugins - Dynamic Plugins.

The main points are adding the plugin to the FMOD Settings under the desired platforms:

Keep in mind to add plugins to Default to be added to all platforms or specific platforms as you add them.

There is a known issue with plugins in 2.02.17 which we are aiming to fix in the next release. In the meantime, a workaround can be found here: 2.02.17 SystemNotInitializedException: [FMOD] Initialization failed : Loading plugin 'OculusSpatializerFMOD' from '__BAD PATH__/Assets/Assets/Plugins/FMOD/platforms/win/lib/x86_64/OculusSpatializerFMOD.dll' : ERR_FILE_NOTFOUND'.

Hope this helps! If you have any more questions about FMOD and its integrations please do not hesitate to ask!